Mobile data counter shows 0 bytes of traffic when WiFi is enabled

asked 2019-06-05 23:43:33 +0300

turboscholz gravatar image

updated 2019-06-06 21:50:13 +0300

I don't know when it started. Maybe after the update to 3.x:

When I open the data counter menu, the following table tells me that I haven't transfered a single bit (sent & received) in the last days. I resetted the counter three weeks ago. It just shows "0 B" in my home network and for Roaming. I actually have a 1GB mobile data contract and I use it constantly, last month my ISP told me that I had ~ 300MB of traffic. Still, my Jolla did not show anything in the counter.

Other peoples reported here that the counter is actually unreliable but I did not see that somebody has the same problem of not counting at all...

The WiFi counter shows values different from 0 bytes, but I didn't check if they are valid - I only care for the mobile data.

So, what can I do to fix this?

Update: It turns out from the comments given below that values are shown when mobile data mode is enabled, i.e. when Jolla is not WiFi mode.

(Device: Jolla Smartphone, Angry Birds edition)

edit retag flag offensive close delete

Comments

1

Yes, I have the same Problem with Jolla1. There is only a spinning Wheel and after ~30min still no Sign of a Statistic. Could be since v. 3.0.3.10 (Hossa) but I am not sure. Stock Jolla Software no Android-Stuff. Ciao Walter

Walter1950 ( 2019-06-05 23:54:00 +0300 )edit

Deactivate the airplane mode then it will work at least for me...

yajo ( 2019-06-06 00:09:49 +0300 )edit

Then you are looking while using wifi!?! If you are using mobile data, you get your data counter for mobile data whith actual numbers. I think this is pretty annoying. I encountered this misbehavior approx. 6 months ago and was hoping since, that this would be fixed soon.

Cheers

tobset ( 2019-06-06 08:07:10 +0300 )edit
1

I recognize this. On my phone (Xperia), the counter only works when I have 'Mobile data' activated, otherwise it shows 0 bytes. Not serious but annoying.

Lars Maria ( 2019-06-06 10:09:52 +0300 )edit

@Lars Maria Interesting find! I can confirm that I have the same problem – I need to have mobile data enabled to actually see numbers. However, I can only access the data counters through the entry in the top-edge menu, if I try opening the page from the Settings app, I only get the spinner as well.

I have experienced this issue for quite a while, probably since around 3.0.2 iirc.

pilino ( 2019-06-06 19:42:40 +0300 )edit