Cannot enable developer mode

asked 2019-06-16 01:11:49 +0300

stef gravatar image

updated 2019-10-28 02:26:14 +0300

objectifnul gravatar image

I realize there are versions of this problem already, but all of them are old (years) and the posted solutions did not work for me. So, here is the problem: I am currently running the Sailfish version prior to on an Xperia X.

  • I tried to update to and get an error saying 'Store could not determine size of update'
  • I waited a few days, hoping the issue would eventually fix itself, however now I also get an 'Critical error in apps registry' error when going into the Jolla store and none of my apps appear under my apps

All suggested solutions indicate to go into developer mode, however: - developer mode appeared enabled on my phone, but I could not set the ssh password. I would activate the option, enter the password, click save and when I left the screen or closed the settings, the option would just return to being greyed out. - because of this I could not use the suggested solutions using devel-su since I cannot set a password for the ssh connection - i tried disabling and enabling developer mode, but it would not disable - I cannot access devel-su since the password I set in the ssh settings is not saved - I then tried rebuilding the apps registry using the Sailfish Utility - this fixed nothing

  • I then deleted some files from the phone (although there was 6.5 gb available) to clear it out to 8 gb available
  • suddenly I could disable the developer mode (oops)
  • I tried to re-enable it and it went all the way to installing developer mode before exiting back to the menu (no error messages), however developer mode remained greyed out. It had however reinstalled the terminal (it was in a different place in my apps)
  • running ssu s returns a ssu.ini does not seem writable. The release is, the domain is sales
  • the version seems to correspond to the Build in the About product menu

Since I cannot enter developer mode, I am a bit stuck. Is there any known solution to this issue?

Thanks a lot in advance!

PS: I should add that I can enter Terminal, but I cannot use devel-su since I cannot set the ssh password. Is there a default password set by any chance?

edit retag flag offensive close delete



Is there any help if you log out of your Jolla Account and then log back in?

Also, Sailfish Utilities in the Jolla Store has the option for specifically fixing the "Critical Error in Apps Registry". Have you tried that (in case you manage to install it)?

teemu ( 2019-06-16 12:02:14 +0300 )edit

I take it you already restarted your phone?

ghling ( 2019-06-16 12:47:16 +0300 )edit

Yes, I've tried both restarting multiple times as well as using the rebuild apps registry utility. Neither of them did anything unfortunately...

I also tried logging out and back in, also no luck. But thanks for the suggestions!

stef ( 2019-06-16 17:16:43 +0300 )edit

Are time and date on your phone correct? That apparently would mess up the SSL certificate if it is mistaken to be from the future.

teemu ( 2019-06-17 07:02:50 +0300 )edit

Double-checked, but yes, these are also fine. It looks a bit like the bgrfs issues described oreviiusly for earlier versions of sailfish os, but I'm not linux or sfos savvy enough to know what that is exactky or how to go about fixing it... Thanks for the tips so far though, maybe they can help someone else out.

stef ( 2019-06-17 08:40:49 +0300 )edit