Media Player: Indexing very slow

asked 2019-06-21 23:43:42 +0300

rozgwi gravatar image

updated 2019-06-21 23:44:33 +0300

After opening the media player it takes between 7 or 8 seconds until any items appear for artists, tracks or albums.
This is quite long given that my library only contains 2800 tracks from about 300 albums.
Getting the playlists (17) to display seems to be even slower, despite having the 4 most recently played present at the start screen.

I'm running Sailfish X on Xperia X and my music is mostly stored on an encrypted sdcard

edit retag flag offensive close delete

Comments

Even without encryption, the indexing is kinda sluggish for me; loading my approx. 1.1k songs takes 4-5 seconds on an XA2.

pilino ( 2019-06-22 14:28:21 +0300 )edit

I have more than 4 000 songs (no encryption) and it takes about 4-5 seconds before they load, but choosing 'Albums' and the first one, it takes another second or two before the songs actually shows and you can play. Xperia Hossa 3.0.3.10, but I think the same behaviour was on Jolla 1 too. And everytime I make a change to a playlist (adding or deleting a song), the programme indexes all artists, all songs, all albums again - deleting a handfull of songs from a playlist and replacing them with other songs takes forever.

Lars Maria ( 2019-06-22 23:16:44 +0300 )edit

I can confirm i have this behaviour even on the j1, irritating i must say...

247 ( 2019-06-23 15:12:43 +0300 )edit

It seems the last update (3.0.3.10) has thrown of the tracker daemon. there's another issue with album grouping

rozgwi ( 2019-06-24 23:36:42 +0300 )edit