Ask / Submit
12

[XA2] NFC auto-enabled after restart

Tracked by Jolla

asked 2019-07-04 15:14:27 +0200

Direc gravatar image

updated 2019-08-06 10:44:56 +0200

jovirkku gravatar image

Hi all,

I have XA2 and XA2 Ultra running 3.0.3.10, and I noticed this: If I restart my XA2, NFC is re-enabled after reboot (at least when Bluetooth is enabled, but I'm pretty sure the same thing happens with both Bluetooth and NFC disabled). For some reason, my XA2 Ultra does not do this; it remembers the state.

The only difference besides XA2/XA2U is that XA2 was flashed with 3.0.3, whereas XA2U was flashed with 3.0.1 (I think) and then upgraded.

Could someone test this? It's quite quick to do ;)

What about XA2 Plus?

edit retag flag offensive close delete

Comments

I noticed this on my xa2.NFC is turned on automatically after every restart. Flashed with 3.0.3.10

babo ( 2019-07-04 15:24:14 +0200 )edit

Can confirm on XA2 Plus also does this on 3.0.3.10 which i flashed to. Guess that's another thing to keep mind of.

Mhaylowe ( 2019-07-04 15:36:24 +0200 )edit

Confirm this behaviour at XA2plus with 3.0.3.10

mitterberger ( 2019-07-11 11:10:28 +0200 )edit

I confirm this XA2plus with 3.0.3.10.

manu007 ( 2019-07-11 11:34:33 +0200 )edit

@Direc Tanks for reporting. I confirm this too on my XA2 Plus Dual-SIM with 3.0.3.10

chris_bavaria ( 2019-07-11 14:20:32 +0200 )edit

2 Answers

Sort by » oldest newest most voted
5

answered 2019-08-01 13:43:25 +0200

jovirkku gravatar image

Thank you for reporting. A bug was filed on this.

edit flag offensive delete publish link more

Comments

Seems fixed after 3.1.0 update atleast for me. Tested when I saw @Direc 's qestion. 17B vendor binaries. Can't recall flashed version. Have to check that later.

Edit 2019-08-02 Definetly flashed 3.0.2. Command: devel-su tune2fs -l /dev/sailfish/root | grep 'Filesystem created' gives Filesystem created: Mon May 6 15:25:48 2019. Remeber that flash script didn't let use 16 binaries.

mSorvisto ( 2019-08-01 22:41:49 +0200 )edit

Fixed for me with 3.2.0 EA upgrade. Was too lazy to do the woraround.

binutzu ( 2019-11-03 23:38:04 +0200 )edit

XA2 plus with 3.2.0.12. NFC automatically turns on after reboot.

zuyev ( 2019-11-13 16:41:22 +0200 )edit

FYI, this also affects my newly flashed Xperia 10 wlth Torronsuo 3.2.0.14. I can turn off NFC for a session, but it is always reenabled after a reboot.

flow ( 2019-12-05 14:12:34 +0200 )edit
2

answered 2019-07-13 17:28:04 +0200

Direc gravatar image

updated 2019-07-13 17:29:31 +0200

As @slava suggested in comments of the question, the folder /var/lib/nfcd/ was owned by root, so I changed the owner to nfc:nfc. In addition there was no settings file in that directory, so I created an empty file of that name, changed the owner, toggled NFC off and the file now contains the setting:

[Settings]
Enabled=false

NFC now stays off when I just rebooted the device.

Sailors, could you also have a look at this? Thanks!

Edit: brainfart fix in settings content.

edit flag offensive delete publish link more

Comments

1

So to make it easy to check; this is correct:

[root@Sailfish nemo]# ls -la /var/lib/nfcd/
total 12
drwx------  2 nfc  nfc  4096 2019-07-03 15:38 .
drwxr-xr-x 33 root root 4096 2019-05-01 15:26 ..
-rw-------  1 nfc  nfc    25 2019-07-03 15:38 settings
Direc ( 2019-07-13 17:33:33 +0200 )edit
1

It's weird. For me, installing nfcd package changes ownership of /var/lib/nfcd directory to nfc:nfc according to %dir %attr(700,nfc,nfc) in the spec file:

https://git.sailfishos.org/mer-core/nfcd/blob/master/rpm/nfcd.spec

slava ( 2019-07-13 18:18:52 +0200 )edit
1

Then I suspect that the permissions are wrong in the flashed image file instead... I didn't try reinstalling nfcd package.

Direc ( 2019-07-15 14:30:29 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2019-07-04 15:14:27 +0200

Seen: 484 times

Last updated: Aug 01