Ask / Submit
4

[Bug][3.1.0.11][XA2] No audio in voice calls

asked 2019-07-19 12:52:11 +0300

Lepton gravatar image

updated 2019-07-23 16:24:33 +0300

jovirkku gravatar image

Since the update to 3.1 I have no audio in voice calls in neither direction. The connection is established just fine, but I and the other person can't hear anything.

I have also tried the bottom speaker (which works fine anywhere else) and headphones, but there still no audio. Even the "Beep" sound when it's ringing on the other side isn't played.

The last time I successfully used this phone to call someone was with a headset. I thought it was somehow stuck in "Headset mode" but replugging the headset also doesn't work.

Any ideas? It seems I am the only with that problem.

edit retag flag offensive close delete

Comments

i cannot confirm, for me it works fine on the single sim xa2! which binary vendor blob version do you have?

manu ( 2019-07-19 13:03:11 +0300 )edit

it was somehow stuck in "Headset mode" but replugging the headset also doesn't work.

Completely stupid question, but: did you check if there isn't excessive dirt stuck in the phone jack? (like very gently cleaning it with a Q-tip) If there's lint stuck in there, that might cause the jack to detect a non-existing headset and "stick in headset mode".

Happens to all my phones (still bearing audio jacks).

DrYak ( 2019-07-19 13:57:30 +0300 )edit

The headphone jack works fine when playing music, it also switches instantly from bottom speaker to head phone when I plug them in.

Lepton ( 2019-07-19 16:09:06 +0300 )edit
1

Had this with 3.0.3.10 some days ago. A reboot helped.

Yo ( 2019-07-19 16:15:15 +0300 )edit

Indeed that worked, but not the first time. Rebooting was the first thing I tried. Didn't work then, but worked now after your comment, so thanks :)

Lepton ( 2019-07-19 17:28:52 +0300 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-07-21 14:49:14 +0300

I had the same issue. These steps worked for me:

  1. Reboot the phone two times
  2. accept an incoming voice call
edit flag offensive delete publish link more
0

answered 2019-08-20 11:13:58 +0300

wosrediinanatour gravatar image

updated 2019-08-20 11:20:13 +0300

Today I had the same issue. Interesting facts: - I haven't used hadset in the hours before. - Phone calls didn't work, with and without headset. - Listen to Spotify worked! - Reboot helped (waited some seconds) - Maybe not related: After restart I sometimes have also problems with texting and/or subscriprion to mobile network.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-07-19 12:52:11 +0300

Seen: 367 times

Last updated: Aug 20