Ask / Submit
0

Package for libgdbm.so.3

asked 2019-07-31 15:02:11 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2019-07-31 15:02:11 +0300

airmont gravatar image

Hi everybody,

Someone knows the package name including the libgdbm.so.3 module on Sailfish X ?

I would like to install avahi-utils package.

I found it on http://repo.merproject.org/obs/home:/fooxl:/sailfish/sailfish_latest_armv7hl/armv7hl/

But no package including libgdbm.so.3

Thanks for your help.

Regards, DJ

edit retag flag offensive close delete

3 Answers

Sort by » oldest newest most voted
0

answered 2019-07-31 18:32:36 +0300

coderus gravatar image

pkcon refresh

edit flag offensive delete publish link more
0

answered 2019-07-31 20:18:18 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2019-07-31 20:18:18 +0300

airmont gravatar image

@coderus

Not working.

[root@Sailfish tmp]# pkcon refresh
Refreshing cache
Refreshing software list
Finished
[root@Sailfish tmp]#
[root@Sailfish tmp]# pkcon update
Getting updates
Finished
No packages require updating to newer versions.
[root@Sailfish tmp]#
[root@Sailfish tmp]# pkcon what-provides libgdbm
Getting provides
Querying
Finished
[root@Sailfish tmp]#
[root@Sailfish tmp]# pkcon install-local avahi-utils-0.7-1.11.7.jolla.armv7hl.rpm libavahi-client3-0.7-1.11.7.jolla.armv7hl.rpm
Installing files
Testing changes
Finished
Fatal error: nothing provides libgdbm.so.3 needed by avahi-utils-0.7-1.11.7.jolla.armv7hl
[root@Sailfish tmp]#

I use the Seitseminen version of Sailfish (3.1.0.11) installed on Xperia X.

Other idea ?

Regards, DJ

edit flag offensive delete publish link more

Comments

libgdbm.so.3 provided by gdbm package, no idea why pkcon cant resolve it for you

coderus ( 2019-07-31 20:23:00 +0300 )edit

It probably provides a newer version:

# rpm -ql gdbm-1.18.1+git1-1.4.1.jolla.armv7hl
/usr/bin/gdbm_dump
/usr/bin/gdbm_load
/usr/bin/gdbmtool
/usr/lib/libgdbm.so.6
/usr/lib/libgdbm.so.6.0.0
/usr/share/licenses/gdbm-1.18.1+git1
/usr/share/licenses/gdbm-1.18.1+git1/COPYING
adekker ( 2019-07-31 22:04:09 +0300 )edit

Ok, I will try a symbolic link.

I come back asap.

Thanks DJ

airmont ( 2019-07-31 23:47:44 +0300 )edit

I'm on 3.0.2 and i have libgdm.so.3

coderus ( 2019-08-01 10:30:40 +0300 )edit
0

answered 2019-08-01 14:01:16 +0300

coderus gravatar image

updated 2019-08-01 14:01:30 +0300

You need to wait until packages will be rebuilt against latest release on OBBS, or take sources and build yourself with latest sdk.

edit flag offensive delete publish link more

Comments

OK, thanks for all @coderus

But, I am not expert to compile sources...

Waiting for new build :(

airmont ( 2019-08-01 19:43:27 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-07-31 15:02:11 +0300

Seen: 187 times

Last updated: Aug 01