Ask / Submit
3

How to enable/disable SMTP/IMAP connection error logging? [answered]

asked 2014-01-30 10:04:22 +0300

ajack gravatar image

Email app does not send emails despite correct SMTP settings. The only error I get is 'Problem with sign-in'.

How to enable, and then disable email error logging so that I can get more specific error msg?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ajack
close date 2014-01-31 00:59:56.280883

Comments

2 Answers

Sort by » oldest newest most voted
3

answered 2014-01-31 16:15:50 +0300

VDVsx gravatar image

@ajack - Maybe I can help you :)

If you have developer mode enabled, in

/home/nemo/.config/QtProject/Messageserver.conf

enable file log and add a path for the log, like for example:

[FileLog]
Enabled=1
Path=/home/nemo/Documents/messageserver.log

Reboot the device and reproduce the problem, send me the log file to vdvtest100 at gmail dot com. After that turn file log off again by setting "enabled" to 0.Thanks a lot!

edit flag offensive delete publish link more

Comments

does this still work? I have no idea what I am doing wrong

 [root@Jolla nemo]# /home/nemo/.config/QtProject/Messageserver.conf
bash: /home/nemo/.config/QtProject/Messageserver.conf: Toegang geweigerd
[root@Jolla nemo]# [FileLog]
bash: [FileLog]: command not found
[root@Jolla nemo]# Enabled=1
[root@Jolla nemo]# Path=/home/nemo/Documents/messageserver.log
[root@Jolla nemo]# [FileLog]
bash: [FileLog]: command not found
[root@Jolla nemo]# Enabled=1[FileLog]
[root@Jolla nemo]# [FileLog] Enabled=1 Path=/home/nemo/Documents/messageserver.log
bash: [FileLog]: command not found
[root@Jolla nemo]#

I cannot get SMTP to work since an update a few months ago. I need some kind of logging since my device only says 'cannot connect'.

Dries Van Giel ( 2015-06-05 22:58:17 +0300 )edit

@Dries Van Giel - yes, but not like that the above is a file you need to open and edit, not commands, updates instructions below.

open file:

/home/nemo/.config/QtProject/Messageserver.conf

edit it in order to enable file log and add a path for the log, like for example:

[FileLog]
Enabled=1
Path=/home/nemo/Documents/messageserver.log

Then restart the device or just restart messageserver5, in a terminal do:

systemctl --user stop messageserver5
systemctl --user start messageserver5

Reproduce the problem, send me the log file to mail-logs at jolla dot com. After that turn file log off again by setting "enabled" to 0.Thanks a lot!

VDVsx ( 2015-06-08 13:03:57 +0300 )edit
1

answered 2014-01-30 10:18:46 +0300

foss4ever gravatar image

updated 2014-01-30 11:50:18 +0300

If you have developer mode enabled you can see something interesting (if not exactly email logs) by usingjournalctlcommand. Just open terminal, andi type the following (before trying to send email):

devel-su

to become root, and

journalctl -af > email.log

Stop command typing CTRL-C, and see the contents of the file with morecommand.

edit flag offensive delete publish link more

Comments

When I hit enter after the second command it goes to a next line and nothing happens. 'bash-3.2' does not show up, just an empty line. Does it mean that I don't have any email logs?

ajack ( 2014-01-30 10:33:00 +0300 )edit

It means that it has started logging to a file 'email.log'. Now, leave the terminal, don't close it, just minimize it, and start doing stuff with email app to reproduce the error, and after that go back to the terminal, press CTRL-D, and you can see what's in the file 'email.log'.

foss4ever ( 2014-01-30 10:38:39 +0300 )edit

So, the point here is that you let 'journalctl'-command gather some logging info that it writes to file, which you can browse afterwards.

foss4ever ( 2014-01-30 10:40:41 +0300 )edit

Thanks jjaone. That makes sense but when I minimize terminal, reproduce error, go back to terminal, press Ctrl-d nothing happens(apart from getting '^[' characters). Do you have any ideas?

ajack ( 2014-01-30 11:03:45 +0300 )edit

@ajack You end the logging by Ctrl-C (which in fact kills the currently running command journalctl)

nephros ( 2014-01-30 11:06:04 +0300 )edit

Question tools

Follow
4 followers

Stats

Asked: 2014-01-30 10:04:22 +0300

Seen: 979 times

Last updated: Jan 30 '14