Ask / Submit
7

Alarm clock with switched off device

asked 2014-01-30 13:15:29 +0200

thewas gravatar image

updated 2014-07-22 11:04:43 +0200

jiit gravatar image

Hi everybody, I can set whatever personal music file as alarm and they works perfectly as long as the phone is switched on. But when it's switched off (e.g. in the night) the alarm sound is set back to the default one. Is there a way to choose the wake-up mood without keeping the device on? ;-) Thx, Thewas

edit retag flag offensive close delete

Comments

1

Why are you switching off your device? Booting of smartphones takes usually more power than having it in flight-mode (if you want to reduce radiation) or even just gsm/umts-standby all night.

chemist ( 2014-01-30 13:40:33 +0200 )edit
2

@chemist Switching into flight mode is not as easy as just holding the power button in to switch off. Or, you might have the phone off already, plugged it in to charge and haven't switched it on again yet. But in any case, why the question? Seems a bit rude.

It's obviously a difference between alarms when the phone is on and alarms when it's off that may be possible to address.

aegis ( 2014-01-30 14:15:00 +0200 )edit

Strange, because some days ago i've switched off it for the night but at the right time in the morning my Jolla wake me up with personal song i've set as alarm..

gordon_pcb_designer ( 2014-01-30 14:21:31 +0200 )edit

@aegis What I can assume is that the ambience defaults override work perfectly until the phone is on, but there is no way to make the device access them in the "partial wake-up" mode in which the alarm starts. When I switch it on again all my settings are there as I left them, and work parfectly.

thewas ( 2014-01-30 14:28:37 +0200 )edit

@gordon Are you using a default ambience or a custom made one?

thewas ( 2014-01-30 14:30:29 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-31 15:07:43 +0200

thewas gravatar image

updated 2014-01-31 15:08:45 +0200

I moved the music file in the phone memory and, magically, the alarm worked perfectly. Unless other experiments contradict me, looks like the alarm "half-boot" of the switched off device doesn't have access to SD card. That means that if you want a specific song for the alarm you have to put it in the phone memory. More attempts will be done when the near-future alarm bug will be resolved. ;-) If nothing happens in the next day I'll set this question as wiki. Thx everybody

edit flag offensive delete publish link more

Comments

you might want to change the question to a bug report, sounds should be stored the way they work and not be just links or alike especially when from sd-card

chemist ( 2014-01-31 15:53:22 +0200 )edit

I also think things should work straight whatever music file you choose, in every condition. A "simple" solution would be automatically creating a copy of all the files that the system may use on the phone memory.

thewas ( 2014-02-01 13:00:32 +0200 )edit

The same problem can occure if the file is on the phone memory but in the android_storage. In this case moving/copying the file to the ~/Music directory solves the problem. If you choose to copy, the one that works should be the second one in the list.

anonymous1 ( 2016-11-11 20:08:18 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-01-30 13:15:29 +0200

Seen: 610 times

Last updated: Jan 31 '14