Ask / Submit
5

[XA2] photos appears green if we have an yellow background

asked 2019-09-05 16:01:13 +0300

cemoi71 gravatar image

updated 2019-09-16 22:07:23 +0300

Hello sailors and jolla devs,

I have the following problems with my xperia xa2 plus and sfos 3.1.0.11 and its former version. I wanted to make a some photos from some insect of a side of an house which has yellow walls.
and was surprised that the photo appears green.
After further investigations, i realized that it appears only if we have a background totally yellow (maybe purple too, but yellow is 100% reproduce-able).
First choose the view to take, and open the app with the view full with the color. A small object maybe be placed in the middle. Important is no other color on the view-borders.
Then open the photo app, or recall it with its cover.
then the view appears green instead of yellow. You may shoot with this color.
Seems that the autofocus is on actioning and do something with a green color and with some colors in background which seems to be plain, then let this a green overlay...

9 videos present the issue here: link text

Photos:

image description image description image description image description image description

and screenshot:

image description

I have videos too which demonstrate that if the app has this color overlays, it records with it. and it disappears by distancing with the device as soon as other colors appears on the borders.

Edit 16.09.2019:
In general the transition between video-mode and picture-mode, or app in background to foreground, have often some lags with this green overlay.
Today appeared 2 bugs (not able to be reproduced), that app from background goes into foreground, and the screen couldn't display the camera view (was only black with no app reaction). The other was the call of the app by lockscreen, password wasn't given. Then the display signal on the screen has flickered...
Photo app need some afterwork for more stability maybe (is only XA2 plus?).

Have a nice sails... cheers

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
1

answered 2019-09-05 20:26:36 +0300

Pohli gravatar image

updated 2019-09-05 20:50:25 +0300

Maybe it helps if you switch off Automatic White Balance.

edit flag offensive delete publish link more

Comments

/\ Yeah, what he said /\

@cemoi71 - just to elaborate on Pohli's answer above. . .

Look at your screenshot, it shows your camera is set to take images with 'fluorescent' lighting, hence the squirly bulb icon above the slider, this adds a blue hue to the images, making your yellow wall, green!

Edz ( 2019-09-05 20:53:00 +0300 )edit

understand...
i've experimented right now with a yellow paper with awb and warm-white led room-light. Quite the same effect... green. but not with other filter.
every time i recall the app with cover i remark a quite long change of color with any kind type of object to take.
seems to be a long period with autofocus and i don't know what else for a filter, which happen a long time (something less than 1s, but quite remarkable for our sight), and is blocked in one algo step....
Anyway, with such a device and it power, this kind of algo should happen in a shorter time, and not block in any step...

cemoi71 ( 2019-09-06 00:13:22 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2019-09-05 16:01:13 +0300

Seen: 246 times

Last updated: Sep 16