Ask / Submit
1

Camera broken after installing Sailfish on Xperia xa2 plus

asked 2019-09-11 12:50:52 +0300

UweKern gravatar image

Hello I have installed Sailfish OS on a new Xperia xa2 plus. Until then, the camera was working on Android. Even after the unlock, the camera still worked.

Under Sailfish, the screen remains black, the camera does not show a picture.

After that, return to Android with EMMA Tool, but now the camera no longer works on Android too.

Any ideas?

Greeting Uwe Kern

PS: I have already asked Jolla, but they do not answer.

edit retag flag offensive close delete

Comments

If camera had been working upon Android might have suggested removing and re-installing under root (pkcon remove & pkcon install) jolla-camera, jolla-camera-settings and jolla-camera-lockscreen. Remember only latest devices running Android Pie that can be bootloader unlocked without breaking camera features and XA2 Plus is not one of them.

aspergerguy ( 2019-09-11 14:43:07 +0300 )edit

Very interesting. I haven't read any of this in the Sailfish OS installation instruction. But that would be worth mentioning. Is there a way to access the phone on Windows, or do I have to configure a Linux machine to do so. SSH is also part of Windows 10.

UweKern ( 2019-09-11 16:06:09 +0300 )edit

Presumably developer mode has been enabled in which case can use installed "Terminal" app upon device. If font too small tap upon three horizontal bars at top right of screen and under "Font size" tap +. Whilst essentially a Mac user, I am sure you can use the likes of "Putty" to SSH into device.

Although it was simple enough to backupTA upon Xperia X devices, this is no longer possible upon XA2 series although some features can be restored using a paid for application Xperifix:link text

aspergerguy ( 2019-09-11 16:38:26 +0300 )edit

Now, I restore Android by using EMMA again. And hey, the Camera works with the Android OS. The APP Xperifix dont support the a2 plus. 19 Euro for usless Software :) Back to Sailfish, same procedure as every year. No Cam. Next, i check to delete and reinstall the Moduls in Terminal. Camera is still broken, Any other ideas?

UweKern ( 2019-09-11 22:39:00 +0300 )edit

3 Answers

Sort by » oldest newest most voted
3

answered 2019-09-24 23:12:23 +0300

JohnW gravatar image

Exactly same problem, Camera of Xperia XA2 plus dual sim completely black after installing Sailfish 3. Helpdesk seemingly clueless. Here is their answer after having asked me to reinstall, which did not help.

Hi,

Thank you for your message!

Sorry to hear that didn't help. This is very rare behaviour for the XA2 Plus that we have not yet run into during our testing. If you could record a log from the Android subsystem while starting the camera, then we might be able to see what's going on with your device.

Please enable Developer Mode, then on a terminal or ssh connection execute the following command:

/usr/libexec/droid-hybris/system/bin/logcat -c

This empties the Android log. Now start recording it to a file with:

/usr/libexec/droid-hybris/system/bin/logcat -f log.txt

This command will not stop writing the log to the file until you press Ctrl+c.

And start the camera. Once the camera is up and running, stop the log and email it to us.

It would also help to take a camera app log by running the following from a nemo terminal (not root):

GST_DEBUG=4 jolla-camera > camera-log.txt 2>&1

It might also help to completely reinstall Android with Sony's Emma tool, verify that the camera works, then reflash Sailfish again. This would reset certain files that Sailfish does not touch, but may be needed for the camera to work correctly. It's a long shot though. Sincerely, Jolla Customer Care

edit flag offensive delete publish link more
0

answered 2019-09-11 14:05:50 +0300

sunburnedpenguin gravatar image

@UweKern, the same thing has recently begun happening to my Xperia X off and on, I guess since after the update to Seitseminen (3.1.0.11). What appears to temporarily fix it for me is to reboot and then run the CSD tool (Settings-->About product-->tap build number 5x-->accept-->All tests-->scroll down to "Main camera and flash"). It will again fail again and show only black at some point, and I'll have to go through the reboot/CSD process again.

edit flag offensive delete publish link more

Comments

Hi, i check the camera with the test and only get the error fail. Reboot the device 3 times, same error. UweKern

UweKern ( 2019-09-11 23:27:19 +0300 )edit
0

answered 2019-09-12 23:05:20 +0300

peakki gravatar image

I've had problems with camera starting with XA2 Dual-Sim. When using android apps for some time, camera app doesn't work or android camera. Workaround before patch: shutdown android support and restart it.

edit flag offensive delete publish link more

Comments

1

Hello, i installed Sailfish on 2 brandnew XA2 plus dual sim and the camera don't work after install. I installed the free Version (without Android Support) too, the same Problem. After a clean Install, the camera is directly broken. Now, i work with Android :(.

Very bad, because i dont like Google anymore. Don't be Evil. Don't make me laugh!

I had great hope in Sailfish, but there is no answer to them. No support. I was looking forward to the next update.

UweKern ( 2019-09-13 10:58:10 +0300 )edit

No. Android 8.1 was installed.

UweKern ( 2019-09-13 12:11:55 +0300 )edit

I have just to confirm @peakki w/a. I do the same when camera stop work in sailfish. Someone should fill bug report against it (or maybe sb already did?)

Edit: Answering myself: https://together.jolla.com/question/207247/bug-camera-app-wont-open-xa2-30310/ Unfortunately it is not tracked by Jolla :(

pemek ( 2019-09-25 12:06:05 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-09-11 12:50:52 +0300

Seen: 567 times

Last updated: Sep 24