We have moved to a new Sailfish OS Forum. Please start new discussions there.
2

How to establish WiFi connection in trains? [captive portal] [answered]

asked 2019-10-27 10:07:09 +0300

ds1979 gravatar image

updated 2020-01-28 22:29:43 +0300

rozgwi gravatar image

Dear Sailors,

I am very often using trains to move along, so I would like to use the WiFi connections on them. Unfortunately, I don't get them to work. In my special case, I have trouble with the WiFi on the trains of GoAgead in Baden-Württemberg. I can connect to the WiFi, but I am not rerouted to the splash page, to confirm that I will obey the law and regulations.

Do you have some tips, what to do?

Thank you in advance!

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by rozgwi
close date 2020-01-28 22:29:25.921341

Comments

2

Try a different browser, Sailfish Browser sucks balls.

Spam Hunter ( 2019-10-27 10:57:43 +0300 )edit

You are right about the browser, though, but I think that this is irrelevant. I can connect to the WiFi, but then nothing happens and no page is being opened, even not starting to load a page, where I can confirm the connection. This in mind, it seems to be a different problem.

ds1979 ( 2019-10-27 11:54:21 +0300 )edit

Oh, unfortunately @Edz is so right about the browser :(

And this is just a minor issue...

peterleinchen ( 2019-10-27 14:27:33 +0300 )edit

@Edz comment is relevant, it's up to the browser to redirect to the captive portal, and Sailfish browser often fail.

Last time I tried, even Firefox didn't manage to do it, but it worked nicely with Webcat.

I'll try to use http next time, as suggested by @Fuzzillogic 👍

Sthocs ( 2019-10-27 15:59:38 +0300 )edit

A train is fitted with a number of Wireless Access Points that can help boost coverage across the coaches TalkToWendys.

Somer5s ( 2020-01-30 12:00:19 +0300 )edit

1 Answer

Sort by » oldest newest most voted
8

answered 2019-10-27 11:55:42 +0300

Fuzzillogic gravatar image

updated 2020-01-27 23:13:32 +0300

ds1979 gravatar image

Try to manually navigate to a site, but make sure to use http, not https, as https will fail due to security. Use http://example.org, for example. Usually, you'll be redirected to the logon page.

However, last time I used public wifi, it just worked for me..

edited by ds1979:

Sometimes you have to delete the cache to make it work. ;-)

This here works in the terminal. Search for my idea to make an icon to write an e-mail to yourself and put it together:

rm -r ~/.mozilla/mozembed/cache2/
edit flag offensive delete publish link more

Comments

1

Exactly this!

peterleinchen ( 2019-10-27 14:26:06 +0300 )edit
4

actually there's a nice site with the http-only (non ssl/https) url: http://neverssl.com I added rhis ro my bookmarks/favourites end vistit it whnenever our beloved bleeding-edge browser doesn't show the captive portal automatically.

jollajo ( 2019-10-27 16:31:38 +0300 )edit
1

Nice one, too.

I always use http://motherfuckingwebsite.com/ :D

peterleinchen ( 2019-10-27 17:05:18 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2019-10-27 10:07:09 +0300

Seen: 874 times

Last updated: Jan 28 '20