We have moved to a new Sailfish OS Forum. Please start new discussions there.
14

[XA2, 10] Fingerprint Scanner not working - dual SIM

asked 2019-11-07 16:17:23 +0300

updated 2020-02-05 11:41:52 +0300

jovirkku gravatar image

I just reinstalled 3.2 on my XA2 Plus Dual Sim, starting from an Android 9.0. Everything seemed working fine, I skipped fingerprint during initial configuration because I wanted to go through a fast restore (ehm, Tutorial).

As soon as I tried adding lock and fingerprint, I discovered there's no way to make fingerprint sensor work. CSD Test procedure shows Fail in red. I also tried resetting and restarting the service, but no way.

Could it be Android 9.0 starting point?

PS On Android fingerprint was working fine.

It seems that dual sims and Android 9 won't go fine together. Better downgrade to Android 8 before installing SFOS.

edit retag flag offensive close delete

Comments

Has anyone a 51.X image to provide? I don’t have Windows PC so no Emma downgrade.

magullo ( 2019-11-08 10:38:12 +0300 )edit

i have no issue on xperia XA2 with android 9 as a base, but i set fingerprint during initial configuration

itdoesntmatt ( 2019-11-09 13:37:53 +0300 )edit

Not a real answer, but thank you for reporting nonetheless.

magullo ( 2019-11-09 15:21:50 +0300 )edit
1

sorry I should have posted is as a comment.

itdoesntmatt ( 2019-11-09 15:25:03 +0300 )edit
2

I am having exactly the same issue, but with a "normal" XA2 dual sim. Installed Android 9, then fresh install of 3.2...the fp scanner wouldn't work. Thinking it might be broken, i flashed Android again but it works just fine there.

Interestingly, I did _exactly_ the same procedure for an XA2 single sim device, and there the fp scanner is working just fine.

looks like this issue is specific for the dual sim devices. haven't tested using Android 8 as a base yet, but it's possible this issue happens in combination of Android 9 and dual sim devices. will try using Android 8 some time this week.

derfelot ( 2019-11-11 03:30:11 +0300 )edit

13 Answers

Sort by » oldest newest most voted
1

answered 2020-01-09 21:05:32 +0300

simc gravatar image

Same issue, for me, XA2, H3113, flashing from Android 9. I skip the initial fingerprint proposal, since not able to define finger to unlock.

edit flag offensive delete publish link more
0

answered 2020-01-02 15:52:44 +0300

I also have a problem with not working fingerprint scanner in H3113. I installed 3.2.1.20 starting from Android 8. It seems that this is a problem in sigle-SIM also.

edit flag offensive delete publish link more
0

answered 2020-04-27 10:42:44 +0300

jovirkku gravatar image

On Sailfish OS release 3.3.0.16, the fingerprint sensors of Xperia XA2 work both on Android 8 and Android 9.

edit flag offensive delete publish link more

Comments

Thank you, as soon as we have images I’ll try flashing from android 9.

magullo ( 2020-04-28 09:11:51 +0300 )edit
Login/Signup to Answer

Question tools

Follow
17 followers

Stats

Asked: 2019-11-07 16:17:23 +0300

Seen: 3,509 times

Last updated: Apr 27 '20