We have moved to a new Sailfish OS Forum. Please start new discussions there.

HowTo: Reset tracker when Gallery app has crashed or SD-card media is not displayed

asked 2014-01-31 13:53:46 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2015-01-21 10:50:00 +0300

eric gravatar image

Hi, I'm having a problem with the Gallery app. I'm using SD card that was previously placed in android phone and where I had some pictures taken by this phone. All pictures were correctly displayed in Gallery when I started the app however I didn't see any picture taken by Jolla camera. Therefore I tried to remove whole picture directory (DCIM/Camera) from SD card but from this point I can't open the Gallery app (crashes everytime I try to open it). I tried to create the directory structure how it was before on the SD card, also tried to copy/delete Camera folder like somebody suggested in different thread but nothing worked. I guess that Reset device could work but do you have any idea how to fix this without reset? Thanks

edit retag flag offensive close delete



have you tried with a reset of the tracker services and its DB? folder hierarchy on your sd-card should not matter in any way.

chemist ( 2014-01-31 14:52:42 +0300 )edit

Thanks for your answer. No, I haven't tried that. How can I reset it?

aleman ( 2014-01-31 15:33:16 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-02-03 23:34:16 +0300

chemist gravatar image

updated 2014-02-03 23:35:21 +0300

tracker-control -es

should do the trick, if not you might need to stop the service and delete all DBs by hand.

See https://together.jolla.com/question/4337/refresh-tracker/ for a general attempt.

edit flag offensive delete publish link more


Thanks again for your answer. The app is working now.

aleman ( 2014-02-04 09:59:40 +0300 )edit

You are welcome ;)

chemist ( 2014-02-04 12:47:58 +0300 )edit

Anybody would like to develop an app for that command line ... ;-)

Upp15 ( 2014-02-09 21:57:53 +0300 )edit

Has worked for me Thanks!

SagaciousT ( 2014-03-06 08:13:51 +0300 )edit

@Upp15 hopefully we do not need an app for it but if you want put it in a shell-script (remember this is no iOS... you can fart your own, no need to have an app for that)

chemist ( 2014-03-06 11:12:08 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2014-01-31 13:53:46 +0300

Seen: 1,275 times

Last updated: Feb 25 '14