We have moved to a new Sailfish OS Forum. Please start new discussions there.
3

SMS messages: "sender does not support replies" phone number formatting problem? [answered]

asked 2019-12-15 00:09:52 +0200

Tinybit gravatar image

updated 2020-01-03 09:20:11 +0200

this is what shows in SMS box. When selecting recipient mobile number from contact same dialog opens with the above message in text input. All grey. Update and clarification 3rd Jan 2020: -the number does contain + in international format, does not contain any other characters. It's same format as other contact which work fine. - the contact itself however does NOT have white dot on right (see screenshot) - contacts are synchronized using CardDAV on Fastmail - not Google account (note other contacts working fine) See screenshot!

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Spam Hunter
close date 2020-01-03 12:52:36.046565

Comments

How is the phone number formatted? Any spaces or characters beyond numbers?

Mohjive ( 2019-12-15 16:49:27 +0200 )edit

I am not sure if I understand correctly. You open the messages app, pulley menu "new message", add a recipient from contacts using the plus-sign and then what? Which version are you using?

Sebix ( 2019-12-18 23:29:25 +0200 )edit
1

I'm having the same issue. I can't send SMS to some senders. Seems linked to formatting as Google adds space in the number, but it does not happen for all contacts. Some contacts with spacing works, others I need to remove the space manually. SFOS X 3.2.1.20 on XA2 Plus.

orangecat ( 2019-12-30 11:44:14 +0200 )edit

@orangecat: What is the relation to Google here?

Sebix ( 2019-12-30 12:09:20 +0200 )edit

I'm using Google contacts to sync my contacts. Most of the contacts were created on an Android phone in the past.

orangecat ( 2019-12-30 12:25:58 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2020-01-03 09:30:09 +0200

Tinybit gravatar image

Problem was solved by editing the contact number: The number look like it was in correct international format starting with +. In desperation I have deleted the plus symbol and replaced it by re-typing. Also I have removed as any spacing between numbers. Now I'm able to send SMS.

edit flag offensive delete publish link more

Question tools

Follow
3 followers

Stats

Asked: 2019-12-15 00:09:52 +0200

Seen: 12,281 times

Last updated: Jan 03 '20