Browser affected by CVE-2019-17026 ?

asked 2020-01-10 11:14:10 +0300

Blizzz gravatar image

Is the native browser affected by CVE-2019-17026https://www.mozilla.org/en-US/security/advisories/mfsa2020-03/ and if so, what is being done against it?

edit retag flag offensive close delete

Comments

7

i think you can be pretty sure that almost all security holes of the last years in firefox are in the jolla browser still....

thats why an update is so urgently needed (and why jolla needs to deliver updates quicker, or update the browser seperately from the os - these things need to be fixed right away)

but thats all wishful thinking :(

misc11 ( 2020-01-10 13:53:27 +0300 )edit
1

Yeah, i am on Fennec from F-Droid atm, and while browsing is decent, the integration into SFOS is not, and the UX has quirks. So, I prefer to keep the Android support stopped again. It's also that, when you do not have the plethora of apps, the browser is doubleplus important.

Blizzz ( 2020-01-12 21:00:53 +0300 )edit