We have moved to a new Sailfish OS Forum. Please start new discussions there.
10

Exchange support got worse with 1.0.3.8 [answered]

asked 2014-02-01 01:50:45 +0300

ridmaur gravatar image

Upgraded to 1.0.3.8 as the release notes indicate finally policies (at least one) is supported. Now I am stuck at configuring my Exchange account at a screen saying the device does not support all policies implemented by the Exchange provider. At least 1.0.2.5 made my bypass this. When are we going to support more policies?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by VDVsx
close date 2014-02-04 19:51:59.882377

Comments

I got the same "error", but the account actually worked. Did you try if yours does?

StefanG ( 2014-02-01 09:29:17 +0300 )edit

Got the same error. So can't use my email from work ... so I can"t use the Jolla :( !!!!

mousse04 ( 2014-02-01 10:40:11 +0300 )edit

same here...

emoeller ( 2014-02-01 12:49:07 +0300 )edit

@StefanG: no, the Oops, ... screen shows Cancel and there is no way the account appears in my list. Completely useless in terms of Exchange support and as other have stated here I have not been able to use my Jolla for work due to the lack of proper Exchange support. This update doesn't help at all.

ridmaur ( 2014-02-01 15:29:45 +0300 )edit

To possibly reproduce the error, I deleted 2 Exchange accounts that were working before. MS Exc 2010 company account w/self-signed certificate plus T-Online.de account. Got the error message with MS Exc, closed the setup swiping down the screen, returned to mail app, account is there and working.

StefanG ( 2014-02-01 16:30:23 +0300 )edit

3 Answers

Sort by » oldest newest most voted
6

answered 2014-02-03 10:59:40 +0300

VDVsx gravatar image

Before this update provisioning was turned off by default, some servers will allow non-provisionable devices to connect, but if you turn provisioning on and the device does not support all policies it won't connect, nothing we can do about that, those are the protocol rules.

If it used to work before the update and the device does not support the required policies, during account setup turn provisioning off, there's an option for that.

edit flag offensive delete publish link more

Comments

Humm I understand now why selecting "no provisionning works" but why, by not selecting the option, Jolla is not able to connect to some exchange servers? Won't you try to make it full compatible? I mean, even the N9 can do it :(.

mousse04 ( 2014-02-03 11:10:36 +0300 )edit

For instance, the policy of my exchange company server request a password locked after 15mns ... but it is not available in Jolla option. So it may come from there that the server doesn't accept my Jolla :(

mousse04 ( 2014-02-03 11:11:56 +0300 )edit
2

We are implementing more policies, it just takes time with very limited resources.

VDVsx ( 2014-02-03 11:18:07 +0300 )edit

Of course I understand ;). Another thing, do you know if the fact that I didn't receive any notifications when a new email arrives is due to the "no provisionning option"? Thanks a lot

mousse04 ( 2014-02-03 11:19:39 +0300 )edit
1

@mousse04 - No, that should work as before, is the email visible in email app ? Notifications are getting some improvements in next updates, sometimes they are not fired immediately if the exchange sync happened in the background, only a bit later.

VDVsx ( 2014-02-03 15:45:55 +0300 )edit
2

answered 2014-02-03 16:05:29 +0300

ridmaur gravatar image

Thanks, turning provisioning off made it work! I was not aware this flag would simply bypass any policies enforced by Exchange.

edit flag offensive delete publish link more

Comments

1

It does not bypass, it just tell the server that device is non-provisinable and some servers accept that, if provisioning is fully enforced in the server side it won't work. You can check in the web ui under options->phone the status of policies applied to the phone.

VDVsx ( 2014-02-03 17:03:28 +0300 )edit

Thanks for the clarification.

ridmaur ( 2014-02-03 17:19:36 +0300 )edit

@ridmaur - Can this be closed now or still need some more clarifications ?

VDVsx ( 2014-02-04 13:31:54 +0300 )edit

I think so; I now can see all my calendar items appearing four times but that's just a completely other problem

ridmaur ( 2014-02-04 17:48:59 +0300 )edit
0

answered 2014-02-04 17:50:18 +0300

ridmaur gravatar image

Solved by turning off provisioning (see comments)

edit flag offensive delete publish link more

Question tools

Follow
5 followers

Stats

Asked: 2014-02-01 01:50:45 +0300

Seen: 1,677 times

Last updated: Feb 04 '14