Ask / Submit
115

bug connection selection loop [released]

asked 2014-02-01 05:07:22 +0200

droll gravatar image

updated 2014-02-01 13:49:53 +0200

TNZ gravatar image

present since the last firmware. enable wifi and 3g/2g data. connect to a wifi hotspot. surf, enable facebook integration etc. walk out of range of the wifi connection. phone constantly shows "Problem with connection" at their top of the screen. ui becomes highly unresponsive, phone heats up as though cpu is pegged at 100%. ui still responds but with a massive lag to touch input (a few seconds). only remedy for me so far is a reboot. looks like network connection code might be stuck in some kind of infinite loop.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by r0kk3rz
close date 2015-01-21 19:50:51.176869

Comments

Done : retag in order to keep the question easily accessible

TNZ ( 2014-02-01 13:52:51 +0200 )edit
1

can this be related? https://together.jolla.com/question/6113/lots-of-connection-errors-while-on-wifi/

i've been having this at times since ever i think, so it's not quite new for me... i always make sure to switch off wifi before leaving the area ;)

egnat69 ( 2014-02-01 15:23:29 +0200 )edit

Problem occured once when i did switch wifi off manually and having excellent 3g connection. i did stop ofono.service, the connection problem -messages did stop, and phone said SIM card was removed. But the touch/swipe delays were still there, and so severe that i couldn't restart ofono. Reboot was the workaround.

kimmoli ( 2014-02-16 22:06:22 +0200 )edit

Is this the same issue as https://together.jolla.com/question/17758/bug-infinite-loop-of-connection-errors/? Bit different description of circumstances, but same symptoms.

ssahla ( 2014-02-22 15:42:00 +0200 )edit

5 Answers

Sort by » oldest newest most voted
36

answered 2014-02-01 13:37:14 +0200

stezz gravatar image

updated 2014-02-15 18:52:19 +0200

Hi,

thanks for reporting this. We became aware of the problem and have a candidate fix for it.


EDIT: Seems we have a fix for this. Testing is ongoing and should be included in next SW update.

edit flag offensive delete publish link more

Comments

1

Could this be a cause of the seemingly random shutdowns? https://together.jolla.com/question/7144/jolla-randomly-shuts-down/

jsiren ( 2014-02-01 13:43:59 +0200 )edit
11

After my question was closed, I've got a wish. As soon as your candidate fix is acceptable for release, can it be released before next update ? I've rebooted my terminal for the 4th time this morning. My jolla is now clearly unusable. I don't say it's urgent but you can heard it as if. :(

TNZ ( 2014-02-01 13:45:48 +0200 )edit
6

@TNZ sure we can consider a hotfix release if the problem is epidemic.

stezz ( 2014-02-01 14:08:44 +0200 )edit
2

do you guys have a small community of beta testers? that might help improve release time and quality (not criticising anyone - thank you for all the hard work already!).

droll ( 2014-02-01 14:59:09 +0200 )edit
5

@droll we don't have yet but are thinking about it.

stezz ( 2014-02-01 15:12:16 +0200 )edit
17

answered 2014-02-01 15:11:05 +0200

TNZ gravatar image

updated 2014-02-12 17:22:13 +0200

Elements for analysis : the loop happens when cellular-network is overloaded. The terminal spends time switching from 2G to 3G (or wifi if activated). The network signal bad quality seems to be the loop origin.

More elements : the main apps stuck is systemsettings. Especialy cellular-network submenu. If I activate wifi near a known network, loop ends and I may switch off 3G data network. It's not only due to signal quality, but cellular network overload too (software disconnection instead of a hardware one). I observe this overload every week-end @ home.

6th Feb : After a phone call, I met a battery drain (95% to 45% in one hour) The phone was hot and I had the blinking red front indicator so I had to remove the battery to reboot. The UI was not responsive anymore. A clue : for the phone call I pressed twice the button and I had a message saying "can't make call during connection of an other one" or approaching.

Reboot/remove battery count : Twice the 11th and once today (12th).

Cellular network switching : I observe just now the following behaviour. My 3G provider signal is lost. So the phone tries to connect to an other provider in 2G via automatic itinerance. Result : flashing green/red front LED.

edit flag offensive delete publish link more

Comments

Had the same yesterday, I had to reboot phone.

Slawek ( 2014-02-07 14:16:46 +0200 )edit

Same here. As already stated by others, it seems to be related to poor 3G connection quality (I was entering an underground parking when it started).

donaggio ( 2014-02-07 15:25:06 +0200 )edit

Similar problem for me just now. Went out for a walk in ~4°C weather with my Jolla in the front pocket. When I came in I tried to wake the phone by double tapping. The LED blinked green and after that the screen turned on. However, the phone was totally unresponsive with a "Problem with connection" message showing at the top; I only had 3G enabled. When the screen turned of it was followed by a few red LED blinks. Had to remove battery to get it working again as I couldn't ssh in to reboot.

Joakim ( 2014-02-08 18:12:20 +0200 )edit

Same for me several time per day. Usually it is when my phone looses the data or the wifi connection, in the metro or in the mountains for example. The phone freezes and I can't use it for a long while. It is surely epidemic.

damourti ( 2014-02-08 19:39:53 +0200 )edit
1

I am experiencing exactly the same: phone overheating like hell, issues in switching form WiFi->3G and lots of 'Problem with connection'. Sometimes i can't even wake the phone up or get green LED blinking. Yesterday i started having random reboots... not cool, specially if you're waiting for calls...

xxhell ( 2014-02-10 13:26:20 +0200 )edit
3

answered 2014-07-22 10:46:48 +0200

Jani68 gravatar image

The problem is here still with Update8!

My phone started to be in that connection problem loop again! Can't you fix this ASAP!!!!!!!

How can you return your Jolla and get money back? This phone does not work and is still pre-alpha stage.

edit flag offensive delete publish link more

Comments

1

the same way you return anything else that is defective. you contact the place where you bought it. they will try to repair it, and when they cant, you ask for a refund. Why would this product be different in any way than a regular process for defective items?

Swl ( 2014-07-22 12:21:27 +0200 )edit

Yes, this problem went back... See also here: https://together.jolla.com/question/51426/internet-connection-issue-when-low-network-since-10819/ (issue also without enabling WiFi)

torcida ( 2014-07-22 12:37:45 +0200 )edit
2

answered 2014-02-13 22:54:58 +0200

clovis86 gravatar image

updated 2014-02-13 22:55:59 +0200

same issue here since last update. also got randomly green/red notification led. phone is almost unusuable ... please release a tiny hotfix for this LOTD, even rebooting without removing battery can't always fix the issue :(

edit flag offensive delete publish link more

Comments

Please fix this ASAP.

BonoNL ( 2014-02-18 00:01:46 +0200 )edit

Have noticed this a number of times. However yesterday when it was in my bag while I was at a meeting it went from 98% to 25% in about 40 mins and was extremely hot. I was actually worried about the overheating. It has only happened since upgrade to 1.0.3.8

sugnea ( 2014-02-26 14:34:12 +0200 )edit
2

answered 2014-03-22 15:27:43 +0200

matrixx gravatar image

Just want to update that I see this one seems to be mostly fixed, at least for me. Thanks for the effort! There is still some small fine tuning left in the connection selection as reported here: https://together.jolla.com/question/35651/bug-losing-mobile-data-connection-when-known-wifi-available-but-no-signal/

edit flag offensive delete publish link more

Comments

Yes, it doesn't happen anymore to me, too

donaggio ( 2014-03-24 17:46:20 +0200 )edit

Question tools

Follow
18 followers

Stats

Asked: 2014-02-01 05:07:22 +0200

Seen: 1,630 times

Last updated: Jul 22 '14