We have moved to a new Sailfish OS Forum. Please start new discussions there.
3

[bug] android apps in landscape mode 3.3.0.16

asked 2020-05-06 15:14:31 +0300

samsy gravatar image

updated 2020-05-06 15:15:59 +0300

Hello sailors,

its the landscape mode again and I dont want to necromance my old thread (https://together.jolla.com/question/207063/bug-android-apps-in-landscape-mode-30310/) but it pops up now bc I saved an edit, sorry for that.

The new landscape error is different, to reproduce:

-phone is XA2 dual (H4113) v16 firmware (last rom was android 9 aosp)

  • open an Android app that runs in landscape mode, for example Netflix, Youtube, NewPipe, Browser (watching a video in it)

  • switch to fullscreen / landscape

  • now you cant switch back to portrait mode

  • after closing the landscape app, all other android apps are now in landscape mode without any chance to rotate back

Fixing it actually by reset android support, thats very annoying.

Can someone confirm or have a fix for this rotation mess? btw. 3.2.1.20 didnt have this error.

edit retag flag offensive close delete

Comments

had the same thing as you, done same thing than you. but by apply a device reboot, then disappeared definitively. did you tried that?

cemoi71 ( 2020-05-07 00:10:06 +0300 )edit

found then that in this sfos version the android apps react more sensitively to the position sensor...

cemoi71 ( 2020-05-07 00:11:17 +0300 )edit

tried restart. bug still there.

samsy ( 2020-05-07 08:08:55 +0300 )edit

really strange it happens to me again and again. Don't know how it is triggered. But if it comes, many apps are blocked in landscape. The only thing to do for me is to start an app which is available to rotate in portrait back again, like the netatmo weather app. Then i may have the other in portrait too.
What i remarked, seems to me that the position detection is really more sensible. It reacts too fast Sometimes it makes jerking a little bit...

cemoi71 ( 2020-06-05 00:33:37 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2020-05-07 12:45:57 +0300

samsy gravatar image

Finally found a workaround I can live with.

Installed Aliendalvik Control, head up to Settings -> Display and deactivate automatic rotation.

Now I can watch Movies in landscape mode and a leaving doesnt grind the other running Android apps.

edit flag offensive delete publish link more

Comments

1

in my case i had to disable and enable the setting once in the android settings. now automatic rotation works

daywalker ( 2020-05-07 14:06:08 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2020-05-06 15:14:31 +0300

Seen: 197 times

Last updated: May 07 '20