Ask / Submit
15

Phone/display fails to wake up after having slept a while

asked 2014-02-01 18:59:15 +0200

Joakim gravatar image

updated 2014-02-01 21:03:14 +0200

stezz gravatar image

My (1.0.3.8) Jolla has started to sometimes fail to wake up after having been put to sleep using gesture (swipe from top of home screen). The same symptom doesn't seem to show up when it has been put to sleep using the power button. However, I haven't had time to thoroughly test this thesis.

When trying to wake it up, the backlight comes on but nothing else happens. Logging in using ssh and killing lipstick brings the display back to life.

Here are som dmesg dumps, don't know if they help:

Before killing lipstick: http://albin.abo.fi/user/jfors/jolla/dmesg_2014-02-01_1658.txt
After killing lipstick: http://albin.abo.fi/user/jfors/jolla/dmesg_2014-02-01_1702.txt

Update

Just woke the device and started getting graphical glitches (colored noise) every couple of seconds, like something was reinitializing in the display stack.

edit retag flag offensive close delete

Comments

The same problem here. Occurs twice so far for today...

Wickedsten ( 2014-02-01 19:23:33 +0200 )edit

Same here, twice also for me today

gordon_pcb_designer ( 2014-02-01 20:55:46 +0200 )edit

This bug occurs very often to me... To reproduce it just unlock and lock (with swipe down gesture) some times. I was unable to bring my screen back today - I had to reboot to fix it.

This is a serious bug please fix it quickly.

Alex ( 2014-02-02 20:01:45 +0200 )edit

I'we had this problem for some time, but sometimes the phone woke up if I was patient enough to wait a while. But now after updating to 1.0.3.8 it's even worse. Now i have to reboot the device every time it fails to wake up.

tapio.oling ( 2014-02-04 19:17:42 +0200 )edit

I facing the same issue. I've noticed that (in my case), it's only happening when my Messages app is in cover mode. It doesn't happen when this app is not running.

I can be wrong : this is only what I am noticing :)

François ( 2014-02-25 15:45:08 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2014-02-05 10:13:43 +0200

spiiroin gravatar image

Sometimes the "fade to black" used in swipe from top of the screen stays active over display off+on. There is internal jolla bug ticket for that.

Meanwhile the display should recover with swipe from top (restarts the fade animation) or bottom (shows events view).

edit flag offensive delete publish link more

Comments

I can confirm this on at least two devices, first noticed it after the recent update.

argontus ( 2014-02-06 18:10:32 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-02-01 18:59:15 +0200

Seen: 379 times

Last updated: Feb 05 '14