We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

[bug] Connman main settings

asked 2020-06-17 19:08:23 +0300

kan_ibal gravatar image

Why variable Nameserver from /home/.system/var/lib/connman/settings is not honoured anymore? It did work a few updates ago.

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
0

answered 2020-06-19 13:04:23 +0300

Andrea777 gravatar image

updated 2020-06-19 13:17:16 +0300

Sakke gravatar image

It is possible to change the nameserver settings. But it is a little bit tricky. You have to edit the connman settings file as root. With help from the Sailors I had the luck to succeed.

Please look to the Thread

Mobile access point - Can I change the WLAN gateway adress? [answered]

edit flag offensive delete publish link more

Comments

Thank you for the answer. I know how it supposed to work and have edited connman settings file and 'Nameservers=DNS IP' in it. It used to work but since 3.2(i believe or so) update it has not been working anymore.

kan_ibal ( 2020-06-19 19:44:00 +0300 )edit
0

answered 2020-06-21 20:58:59 +0300

Afaik (and that may be wrong!) connman listens on 127.0.0.1:53 and proxies the nameserver(s) given from router/gateway.

Further more I have no nameserver option under /home/.system/.../settings on my SFOS 3.2.1

You might try to configure manually:

connmanctl help
connmanctl services
#connmanctl config wifi-ggguuuiiiddd --ipv4 manual 192.168.100.100 255.255.255.0 192.168.100.1
connmanctl config wifi_ggguuuiiiddd --nameservers 8.8.8.8

And see if it works under Sailfish. And if whether it survives a reboot. (you might check the configuration file)

edit flag offensive delete publish link more

Comments

1

I know that, please see DNS proxy

kan_ibal ( 2020-06-28 21:27:47 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2020-06-17 19:08:23 +0300

Seen: 392 times

Last updated: Jun 21 '20