We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

Backup fails: [ERROR] 1 Cannot load working directory! [answered]

asked 2020-07-05 10:44:05 +0300

J.Foerster gravatar image

updated 2020-07-05 10:44:34 +0300

Since I reflashed my device after an update broke it, I can't backup anymore. Currently running Sailfish OS 3.3 on Sony Xperia XA2 Ultra

The logfile says the following:

Status = Preparing
    [UI] Preparing to backup files to /run/media/nemo/fbad08b7-5439-426b-83dc-08f77c5ee5eb/sailfish_backup_2020-07-05T07-39-14Z.tar
    Failed to create directory! /home/nemo/.local/share/system/privileged/Backups-tmp/units/sailfish_backup_2020-07-05T07-39-14Z
    [ERROR] 1 Cannot load working directory!
    Status = Finalizing
    [UI] Beende Operation
    Status = Finished
    Removing working files in /
edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Sakke
close date 2020-07-05 12:33:28.331679

1 Answer

Sort by » oldest newest most voted
1

answered 2020-07-05 11:03:03 +0300

J.Foerster gravatar image

Ok, after a bit of debugging I found out, that the group-owner of the directory was actually wrong and the user 'nemo' had no write access to it.

I would suggest everyone who runs into a similar problem checking the existence, permissions and ownership's of the given paths from the log-file.

Why the log just couldn't say "permission denied" is beyond me.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2020-07-05 10:44:05 +0300

Seen: 79 times

Last updated: Jul 05 '20