Ask / Submit
34

1.0.3.8 introduced bug in app minimizing and close [answered]

asked 2014-02-03 00:26:21 +0200

cquence gravatar image

updated 2014-07-30 16:47:51 +0200

jiit gravatar image

After installing 1.0.3.8 all the applications do not minimize as they used to. All gestures from the side (either left or right) do not have any effect 8 out of 10 times. Most of the time navigation actions inside the application take place instead of minimizing. I am explicitly and relatively slowly trying to swipe from either edge of the screen (left/right) but there is no minimize action. Close action (swipe from top) is a bit better and swiping from the bottom displays consistently and effortlessly the notification center.

Swipe from the bottom is the only swipe gesture that works OK as with 1.0.2.5. Do other people have the same problem? It really ruins the UI experience. My only workaround at the moment is the lock key and then by unlocking I end up in the lock screen and into the task view with all the tiles of the running applications.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by molan
close date 2014-06-05 11:04:12.324113

Comments

1

same issue here. doesn't happen all the time but when it does, it stays that way all the time. i had to reboot a few times to remove the issue.

droll ( 2014-02-03 01:51:05 +0200 )edit

Yes, although reboot didn't always solve the issue for me; it was usually the same after rebooting. As replied below this is being worked on, so we should have a fix at some point.

cquence ( 2014-02-03 01:56:23 +0200 )edit

Happened to me as well. I have noticed that when I have issues with connection and I restart connman - this behaviour is immediately present. So may be this can help.

zlatko ( 2014-03-02 18:58:10 +0200 )edit

AFAIK the problem/bug ist still present in 1.0.4.20. Any ideas when this will get fixed?

naytsyrhc ( 2014-04-07 09:51:20 +0200 )edit

Since 1.0.4.20 this error is not occurring on my device.

lomo ( 2014-04-07 10:22:42 +0200 )edit

3 Answers

Sort by » oldest newest most voted
19

answered 2014-02-03 01:04:16 +0200

Venemo gravatar image

updated 2014-02-07 12:11:42 +0200

The Jolla guys have confirmed that they're working on this.

Basically, we found this bug today at FOSDEM (we updated our phones yesterday). At some point, Markko (Sage) had it on his device too. Anyway, the relevant thing is that the right people know about this and are working on getting a hotfix out.

NOTE: a reboot will temporarily fix the problem.

edit flag offensive delete publish link more

Comments

Thanks for your input. It is good to know that this is known and is being worked on. I will accept this as an answer. Thanks again!

cquence ( 2014-02-03 01:11:21 +0200 )edit

Happens to as well. Sometimes it very frustrating not to be able to leave application.

It seems that if you do the gesture by tapping the screen border (don't take your finger off the screen) for a moment (about 0.5 sec) and then start the swipe gesture it's being recognized correctly.

lomo ( 2014-02-03 17:28:35 +0200 )edit

Ok thanks for this, I will try it next time ti happens. (I had it twice today already, fixed with a reboot)

cquence ( 2014-02-03 17:42:08 +0200 )edit
1

I experience this issue very often. Reboot helps only sometimes. I hope for a hotfix as phone begins to be unusable with this bug.

lomo ( 2014-02-04 12:42:24 +0200 )edit

I'm experiencing this too. It's very difficult to move from app to app.

Stuarty ( 2014-02-06 14:27:55 +0200 )edit
5

answered 2014-02-04 22:38:39 +0200

steph gravatar image

Closing https://together.jolla.com/question/24141/bug-some-gestures-broken/ as a dupe of this, text here:

I've hit this twice now since upgrading to 1.0.3.8 First time I noticed it I was in an android app, this time fingerterm but that may just be anecdotal.

Symptoms:

  • I'm unable to peek to the home screen from within apps, it's as though the device doesn't recognise it, for example if I do it in the mail app in the bottom half of the screen (where the message previews are) it attempts to highlight them instead.
  • I'm able to get to the home screen but in order to do so I must swipe horizontally very quickly
  • Swipe down to go to sleep works normally, however swipe to close an app must also be done very quickly
  • Swipe up to notifications peeks and works as normal.
  • All gestures in apps themselves seem to work normally (e.g. vertical scrolling, tapping, horizontal scroll to sub-dialogues etc.)
  • Horizontal swipe to ambiances works as normal in the homescreen/lockscreen

Nothing will recover the device to normal behaviour except a reboot.

@casanunda also reports:

  • swipe down to close app doesn't work
  • swipe left/right to go to home screen doesn't work
  • swipe left/right on home screen to go to ambience works fine
  • swipe up to go to notifications works fine
  • hitting power button to switch off screen and then working my way back to home screen an into one of the apps works fine (no other way to get out of an app).
edit flag offensive delete publish link more

Comments

I can confirm that I have the exact same behavior as you. Didn't know about that a fast swipe actually works (as you mention in your second bullet) but it seems to be the case for me as well (thanks for the tip).

Xiph ( 2014-02-05 17:51:34 +0200 )edit

I don't know if it's related, but I got this bug now, and journalctl -qaf shows: Feb 28 23:34:52 localhost lipstick[15508]: [W] unknown:44 - qrc:/qml/ConnectionStatusIndicator.qml:44: TypeError: Cannot read property 'state' of null everytime I try to side swipe and it doesn't work. The bug was somehow triggered in the events view.

Acce ( 2014-02-28 23:38:06 +0200 )edit
1

answered 2014-02-03 00:36:40 +0200

GuSec gravatar image

updated 2014-02-03 00:36:58 +0200

I had this problem to a frustrating degree with switching the layouts (of the input keyboard) on the N9. What I found out, was that by cleaning my screen I got a huge increase in success. I'm not saying that you have a dirty phone, but have you tried to see if something is blocking the edges of the screen (and therefore the correct interpretation of the gesture)?

edit flag offensive delete publish link more

Comments

I thought about something being suddenly different, either the screen or my hands :P but why would it make a difference only on the horizontal and not on the vertical? I will try cleaning the screen and see if anything is around the edges, thanks.

cquence ( 2014-02-03 00:47:05 +0200 )edit

Question tools

Follow
8 followers

Stats

Asked: 2014-02-03 00:26:21 +0200

Seen: 776 times

Last updated: Feb 07 '14