Ask / Submit
7

Sygic android navigation application stop to work after 1.0.3.8 update

asked 2014-02-03 14:20:09 +0300

antti10 gravatar image

updated 2014-02-28 00:53:38 +0300

Edz gravatar image

I have Sygic android navigation application that works fine after 1.0.2.5 update. Only thing that not worked was satellite display. After 1.0.3.8 update speed information disappeared and position indicator starting jumping around a map. instead that satellite display start's to work. Is that possible to restore phone GPS settings to situation what was before 1.0.3.8 update?

edit retag flag offensive close delete

Comments

would it be possible that the application is trying to smooth gps/location data, which would cause jumping around the map. I've seen this few Android apps and those have had possibility to disable smoothing -> jumping stops.

tigeli ( 2014-02-03 14:26:04 +0300 )edit

I liked the Sygig-Maemo version and almost bought the Andriod-version. The fact is that we need a native voice navigation. I hope this is coming soon and looking forward to download whole countries plus offline navigation! The Here-maps guy should have the best map material. So far I'm using my N9 for car navigation.

Marti Masa K ( 2014-02-08 16:01:22 +0300 )edit

"Lucky" guys, if it (Sygic) works for you at least a little bit: I do not get any satellite fix since update to 1.0.3.8 -- having it running and trying to get a location for more than an hour!

jgr ( 2014-02-09 23:51:14 +0300 )edit

Sygic is working again on 1.0.4.20 for me.

cocof2001 ( 2014-03-27 10:12:22 +0300 )edit

without loss the GPS position? again and again...

free-mg ( 2014-03-28 10:24:17 +0300 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2014-02-03 15:29:18 +0300

antti10 gravatar image

I think that problem is not application, because it starting to work normally after 1.0.2.5 update. But same problem what was before that returns after 1.0.3.8...

edit flag offensive delete publish link more
1

answered 2014-02-08 15:25:30 +0300

TellienInTouch gravatar image

I have exactly the same problem since 1.0.3.8 update!

I bought Sygic because Here application is really bad on Jolla and everything works except that the GPS position is always outside the road when I am in navigation mode.

It seems to be a lots of GPS problems in 1.0.3.8 update... It's a bit sad, built in GPS application is not good and others are not working well!

edit flag offensive delete publish link more

Comments

I have exactly the same problem too

free-mg ( 2014-02-08 15:32:57 +0300 )edit
0

answered 2014-05-02 18:04:52 +0300

TellienInTouch gravatar image

updated 2014-05-10 10:39:36 +0300

I just found a solution to get a good GPS fix on the latest version of Sygic 14.0.2 (perhaps it works for earlier versions too).

You have to edit the file /data/sdcard/Sygic/Android/settings.ini and replace the line "m_strDefCom=GPS,9600,3" with "m_strDefCom=GPS,9600,2"

Without restarting the application, you must delete the file settings2.dat (all personal settings will be lost) and then start Sygic.

These parameters correspond to the values ​​used in the 11.2.6 version of Sygic which seemed to work better.

[EDIT] If you have a problem with the licence (if you have already buy one), you must write your IMEI instead of the world imei in "m_str_DrvDevice=imei" in the file settings.ini (and delete settings2.dat) because Alien Dlavik seems to not have access to the right IMEI and the licence could only be activated with your unique IMEI.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-02-03 14:20:09 +0300

Seen: 2,175 times

Last updated: May 10 '14