We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

mtp bug: read operation not supported [answered]

asked 2014-02-03 21:37:20 +0300

updated 2014-02-22 02:49:15 +0300

Since the update to 2.0.3.8 I am having trouble accessing files over usb/mtp.

When trying to copy some files from the phone to my computer in the command-line I get a:

cp: cannot open ‘20140126_030.jpg’ for reading: Operation not supported

I did manage to copy over some video files (those that came with the Jolla) without any problems once. So perhaps it works sometimes only. At least browsing the directories works flawlessly and fast.

Before the update I didn't have these problems.

This was tested on Ubuntu 13.10.

Related to https://together.jolla.com/question/3700/usb-pc-connection-ubuntu-1310-doesnt-work/

EDIT: You might need to uninstall the 'python-nautilus' package. See: http://askubuntu.com/questions/400355/nautilus-crashes-at-start/424403#424403

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by avdwoude
close date 2014-02-22 02:47:13.625078

Comments

I tried to access my photos for the first time today. When I plug the phone in my table (Asus Transformer), Android offers me to open Camera Importer. When I do that the app says "There is no MTP device connected". Also the Gallery app or any of my file browser apps don't recognize Jolla being connected at all.

AnaT ( 2014-02-04 11:43:43 +0300 )edit

Btw, are you sure this is not a duplicate: https://together.jolla.com/question/3700/usb-pc-connection-ubuntu-1310-doesnt-work/

AnaT ( 2014-02-04 11:47:26 +0300 )edit

@AnaT It is a indeed a duplicate. But I do still wonder why did it work without any real issues before and stopped working after the upgrade to 1.0.3.8.

avdwoude ( 2014-02-04 13:01:54 +0300 )edit

So you're having a 64 bit Ubuntu also? Please close this question as a duplicate, then. I suppose I'll have to create another bug report due to my Android issue...

AnaT ( 2014-02-04 14:51:27 +0300 )edit

No this is on 32 bit Ubuntu.

avdwoude ( 2014-02-05 15:37:21 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-02-22 02:41:08 +0300

Apparently the problem wasn't Jolla or libmtp or such. Nautilus was generally crashing often on creating thumbnails or such. I suppose with some of the photos this bug got triggered. Apparently this isn't directly a Nautilus issue either as Nautilus started working properly again after uninstalling the 'python-nautilus' package. It no longer crashes accessing Jolla over mtp.

I found info here: http://askubuntu.com/questions/400355/nautilus-crashes-at-start

edit flag offensive delete publish link more

Comments

Hmmm Nautilus doesn't crash and I can copy over files, but opening a file directly is somehow not working yet. But I can do what I need to do so I am happy enough for now. I'll leave this question closed.

avdwoude ( 2014-02-22 02:54:38 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2014-02-03 21:37:20 +0300

Seen: 668 times

Last updated: Feb 22 '14