We have moved to a new Sailfish OS Forum. Please start new discussions there.
6

[Bug]: flickering while peeking

asked 2014-02-04 12:58:24 +0300

mcfrisk gravatar image

updated 2014-02-24 23:39:14 +0300

clau gravatar image

Since update to 1.0.3.8 peeking form apps like gallery to running apps and clock list is not smooth. The main app like gallery is flickering on and off before the running apps shows completely. With previous SW release peeking was smoother on the GUI.

edit retag flag offensive close delete

Comments

It seems to depend on the speed of swiping, if it is done slowly it is a smooth fade, but if it is done quickly it looks wrong. For example if going back to the home screen by swiping quickly from the left or right edge the clock instantly appears at full brightness, then disappears quickly, then fades in as at should as the finger continues to move.

markcoley ( 2014-02-05 00:39:11 +0300 )edit

I'm not doing the swipes fast. Just a normal day-to-day thumb swipe from gallery to home screen and the flickering is clearly there. I need to do it really, really slow to not get the flickering effect and to get the fade/merge effect with a smooth transition.

mcfrisk ( 2014-02-10 11:51:33 +0300 )edit

I have this problem too, and it's quite random, and very annoying. It depends on speed, but sometimes it works correctly regardless of the speed.

clau ( 2014-02-14 12:10:58 +0300 )edit

There seems to be an improvement in 1.0.4.1. Check the video from here.. However, occasionally I could still notice the flicker, for instance at about 2:35 into the video, when peeking out of Store.
There's still time until we get the next update, let's hope it will be completely gone by then.

clau ( 2014-02-24 23:45:32 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-03-18 11:10:35 +0300

mcfrisk gravatar image

Seems to be fixed in 1.0.4.20 SW, or performance is just better. With 3.8 it was there all the time, with 12 hours on 4.20 haven't noticed this at all. IMO, fixed.

edit flag offensive delete publish link more

Comments

I don't think it is fixed in 1.0.4.20, at least I have this behavior all the time when peeking or swiping in 1.0.4.20. Sometimes I can even stop approx. 1 mm after the screen edge and have 100% visibility to the home screen for few seconds.

soloist ( 2014-04-01 11:39:48 +0300 )edit

I agree, first I wasn't seeing this anymore but now after several days of uptime on Jolla I see it again too.

mcfrisk ( 2014-04-01 11:53:15 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-02-04 12:58:24 +0300

Seen: 156 times

Last updated: Mar 18 '14