Ask / Submit
14

Request: A clearer indication that SIM card is not activated

asked 2014-02-05 10:26:24 +0200

Wizah gravatar image

updated 2014-07-30 16:15:22 +0200

jiit gravatar image

I just noticed that I couldn't send an SMS for some reason. Took me a while to notice that there was not network connection and then I noticed the "Activate SIM card option" and remembered that I probably forgot to enter the pin code yesterday when I restarted the phone.

This could have lead to a lot of missed calls.

I think it should tell you that you have to "activate the SIM card" or "type in the PIN code" and maybe show the PIN code number pad automatically.

edit retag flag offensive close delete

Comments

I think the average user will expect to be notified if the SIM is not active after starting the phone (or changing back from airplane mode). However don't force users to input the pin to use the device, supply at least a dismiss/cancel button there.

marsch ( 2014-02-05 11:26:07 +0200 )edit

My Jolla skips the PIN code request since a couple of weeks ago. This combined with the low battery notification and shutdown even when plugged in at night makes it really annoying.

Wizah ( 2014-02-14 23:18:43 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-05-18 14:54:03 +0200

oitos gravatar image

updated 2014-05-18 15:42:21 +0200

For those of you that are experiencing that the Jolla entirely skips the SIM unlock screen:

After updating my Jolla recently, either v1.0.4.20 or v1.0.5.16 I believe, my Jolla no longer requested me to unlock my sim card.
To be clear, it didn't do this at any point. It would simply skip the process entirely, and I would have to go to the Settings application and activate it.
After a factory reset and upgrade to newest version (v1.0.5.19), I can report that this issue is no longer existing.
It would seem that a conflict can arise when updating a non-clean/running install.

If you are experiencing this issue and cannot be bothered to reinstall your phone presently, then I recommend to activate your SIM the following way:
1. Open Settings application
2. Select "System Settings"
3. Select "Internet Sharing"
4. Pull down top menu and select "Activate SIM card"
5. Enter PIN when prompted
6. You can now exit the settings app again with SIM card activated

The reason for using the Internet Sharing menu instead of the Mobile Network menu is that when using the latter, my phone would, in most cases, display "loading settings" indefinitely, which seemed to eat up battery in the process.
When using Internet Sharing, this never happened and the settings in Mobile Network menu would appear instantly.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-02-05 10:26:24 +0200

Seen: 239 times

Last updated: May 18 '14