We have moved to a new Sailfish OS Forum. Please start new discussions there.

What to do if you start getting "USB device not recognized" in Windows when connecting your phone through USB?

asked 2014-02-05 13:27:47 +0300

typo gravatar image

updated 2014-02-05 13:43:25 +0300

Sometimes, when you keep connecting and disconnecting your phone to your Windows PC through USB, you may start coming across the issue of Windows complaining "USB device not recognized" when connecting the phone.

This may also affect other USB-connected devices e.g. the first time I came across this issue, I didn't only lose the phone connectivity but my mouse stopped functioning as well.

So how can you resolve this? I struggled with this for a bit but then found a solution that is so trivially simple I could hardly believe it. See the answer below.

edit retag flag offensive close delete


Note: This is not necessarily just a Windows issue but I have only come across this with Windows and have no knowledge of the way Linux and Mac handle USB enumeration so I can't speak for the other operating systems here. Any input on Linux and Mac behavior would be most welcome.

typo ( 2014-02-05 13:46:35 +0300 )edit

with Harmattan MeeGo I never have this problems!!! I did copy and remove all craps I wanted

michdeskunk ( 2014-04-12 15:54:45 +0300 )edit

This problem just started for me after I updated to Iijoki. Tried two different Windows-computers with same problem. :/

paperboy ( 2017-02-19 15:07:15 +0300 )edit

In windows 8 pro (32bit) It was working MTP drivers Of aqua fish but since EA It says connected but doesnt shows anywhere On My PC

p_pahare ( 2017-02-26 16:32:37 +0300 )edit

5 Answers

Sort by » oldest newest most voted

answered 2014-02-05 13:47:09 +0300

Khertan gravatar image

An other option is to use Linux ... and get rid of Windows

edit flag offensive delete publish link more



Hardly an answer! There are a multitude of reasons why some may be stuck with Windows and moving to Linus is not a possibility.

bockersjv ( 2014-02-05 13:49:27 +0300 )edit

answered 2014-02-05 13:40:27 +0300

typo gravatar image

updated 2014-02-05 13:55:11 +0300

So here is the solution and (simplified) explanation:

Just simply turn off your computer and unplug all power sources (excluding the CMOS battery) from it. In the case of a desktop computer this probably means just detaching the power cord and, in the case of a laptop, detaching the power cord + removing the laptop battery.

Then wait for a little bit (just to make sure that the motherboard is completely drained off of all power - for example it takes my desktop PSU about 1,5 minutes for that to happen).

After that, just boot up normally and the problem should have vanished (for a while anyway).

The reason why this happens is, at least partially, because of the way Windows handles USB enumeration; it tends to run out of available USB IDs over time (kind of like a DHCP server handing out IPs without a lease expiration time) all of which are stored by a microcontroller on your PCs motherboard. Completely remove power from the motherboard, that storage is cleared and you can start afresh until the same happens again, later on.

edit flag offensive delete publish link more

answered 2014-10-09 22:31:49 +0300

simo gravatar image

Missing drivers are another, maybe even more common reason. Refer to: https://together.jolla.com/question/2565/windows-drivers-for-jolla-usb/

edit flag offensive delete publish link more

answered 2017-02-18 14:03:58 +0300

Zumbs gravatar image

Installing Windows Media Player fixed the issue for me.

Background: I had the same problem as described, getting the "USB device not recognized" error when connecting to my Windows 7 Pro N 64 bit PC. It was strange, because it had worked previously, however, I had also done a restore to a half year old system image as I had managed to screw up windows update. After reverting I could not get it working, so I ran through the steps suggested here, including a reinstall of the mtp drivers, but none of them worked for me.

Some time later I needed to use Windows Media Player, and was surprised to see that it had reverted to its base state (Windows Pro N comes without Windows Media Player). After the installation, I could connect and mount my Jolla phone. It looks like the mtp drivers require some interaction with Windows Media Player to work correctly.

edit flag offensive delete publish link more

answered 2017-02-18 15:36:00 +0300

wosrediinanatour gravatar image

In my case, it helped, when I used a shorter cable.

edit flag offensive delete publish link more


My Windows 7 does this with the Aquafish dual boot with either Linux Mint or Elementary OS both work 100% with my Aquafish +Jolla1

djhowls ( 2017-02-18 16:05:47 +0300 )edit

I was having this problem as well and couldn't find a solution, but substituting a shorter USB-C cable did the trick. I have no idea why that would make a difference but it worked.

Oldmil ( 2020-07-02 16:21:33 +0300 )edit
Login/Signup to Answer

Question tools

1 follower


Asked: 2014-02-05 13:27:47 +0300

Seen: 1,541 times

Last updated: Feb 18 '17