We have moved to a new Sailfish OS Forum. Please start new discussions there.
19

Possible to disable vibration for emails?

asked 2014-02-05 16:07:36 +0300

m-m gravatar image

updated 2014-02-20 21:55:06 +0300

ssahla gravatar image

I'd like to have option to disable vibration for email notification. I know will have new emails anyway and it is just question of time when I will have time to process them, therefore no notification is necessary for them.

Now there is only option to disable sound for emails and vibration is either enabled for all events or for none.

edit retag flag offensive close delete

Comments

You still would like to receive notifications in events view, or is this request to disable notifications entirely ?

VDVsx ( 2014-02-05 17:54:45 +0300 )edit

I did not look into it (have my Jolla not at hand), but there should be a pattern for each notification. On the N900 there were patterns for missed call, received email, received SMS, received chat message, battery loading, battery full, etc. So each can be adjusted individually and each pattern had a priority - e.g. incoming SMS is more important than "battery full - remove charger".

codeboss ( 2014-02-05 17:59:39 +0300 )edit
1

Events view notifications are very welcome but I'd love to have control for vibration and sounds per notification type. Having couple of busy email boxes means that the device is buzzing all the time. Sound control is already there so maybe this could be implemented easily.

m-m ( 2014-02-05 20:32:33 +0300 )edit

like I said - LED and vibration patterns are in /etc/mce. Until there is a GUI available, editing those files there is an option.

codeboss ( 2014-02-05 20:36:37 +0300 )edit

Thanks, this thread seems like a good place to start: http://talk.maemo.org/showthread.php?t=42091

m-m ( 2014-02-06 09:39:54 +0300 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2014-03-23 00:24:59 +0300

ssahla gravatar image

updated 2014-03-23 12:07:40 +0300

Here’s a workaround, requiring Terminal.

Make backups of the settings files before editing them!

First, define a new vibration effect NGF_NONE by editing /usr/share/ngfd/plugins.d/ffmemless.ini.

On this line:

supported_effects = NGF_SHORT;NGF_LONG;NGF_STRONG;NGF_BATTERYLOW;NGF_RINGTONE;NGF_CLOCK;NGF_SMS

add NGF_NONE to the list, separated by a semicolon:

supported_effects = NGF_NONE;NGF_SHORT;NGF_LONG;NGF_STRONG;NGF_BATTERYLOW;NGF_RINGTONE;NGF_CLOCK;NGF_SMS

Effects are defined later in the same file, like this:

NGF_SHORT_TYPE = rumble
NGF_SHORT_DURATION = 240
NGF_SHORT_DELAY = 0
NGF_SHORT_MAGNITUDE = 27000

Insert a new definition with the others:

NGF_NONE_TYPE = periodic
NGF_NONE_DURATION = 1
NGF_NONE_MAGNITUDE = 1

Second, select the newly defined effect for email by editing /usr/share/ngfd/events.d/email.ini.

Replace each of these lines:

ffmemless.effect = NGF_SHORT
ffmemless.effect = NGF_LONG

with

ffmemless.effect = NGF_NONE

Reboot your phone. Now email notifications won't vibrate.

Notes:

  • I did this by defining a new non-effect, because just deleting the ffmemless.effect lines in email.ini didn't work.
  • Duration and magnitude are set as 1, because with values of 0 there still was a quick vibration.
edit flag offensive delete publish link more

Comments

Update: It seems that you can just delete the entries in email.ini, no need to define a new effect. (This was maybe changed in an update or I did something wrong when I first tried that.) See https://together.jolla.com/question/46415/wiki-how-to-disable-email-notification-force-feedback/

ssahla ( 2014-08-19 17:35:07 +0300 )edit
1

There should be no backup file of email.ini in the same directory, otherwise it won't work! (At least it didn't for me.)

femtopeta ( 2016-05-11 17:08:16 +0300 )edit
0

answered 2014-02-05 16:57:18 +0300

codeboss gravatar image

updated 2014-02-05 18:01:03 +0300

On Maemo (N900) there was a mce.ini in /etc with all LED and vibration patterns including a very good documentation how to create those patterns (later, of course, someone also made an app to do so via GUI). As Sailfish is a successor of Maemo it might be worth a look. /etc/mce* (you would probably need development mode to change that file)

Additional WARNING: bricking that file could result in endless-boot for N900 - so be careful!

edit flag offensive delete publish link more

Comments

After checking the 10mce.ini file I haven't found simple for removing vibration from email notification. The configuration file is nicely commented but there are no vibration pattern definitions which could be commented out. Just a guess but maybe Jolla triggers the vibrations based on some of the LED settings.

m-m ( 2014-02-12 12:40:24 +0300 )edit

I also didn't find vibration patterns in /etc/mce, only led patterns. And changing the led patterns doesn't change vibration behavior.

In /usr/share/ngfd/plugins.d there are files where vibration patterns are defined, and in /usr/share/ngfd/events.d there are .ini files for different events where those patterns are referenced. I don't know if these could be modified to change the vibrations. (I tried removing the vibration pattern from email.ini but it doesn't seem to do it – incoming emails still alert with vibration.)

ssahla ( 2014-02-13 00:59:10 +0300 )edit
Login/Signup to Answer

Question tools

Follow
8 followers

Stats

Asked: 2014-02-05 16:07:36 +0300

Seen: 589 times

Last updated: Mar 23 '14