We have moved to a new Sailfish OS Forum. Please start new discussions there.

Still can't send mails [answered]

asked 2014-02-06 01:33:30 +0300

naytsyrhc gravatar image

updated 2014-08-04 17:21:26 +0300

jiit gravatar image

So all questions I see concerning sending of mails seem to be closed and fixed. But how comes, that I still can't send mails from my Jolla? I don't get any error messages nor can I find any evidence of the sent mail in Outbox or Sent folder.

I'm using the german mail provider GMX and use IMAPS (port 993) for incoming mails and SMPTS (port 465) with password authentication for outgoing mails. I can receive mails, but I can't send any (I jused the same settings on my N9 and it worked - it also works with thunderbird).

I also tried to check settings via ag-tool as suggested in one of the answers of the other questions concerning mail sending, but everything seems fine (username is correct and server settings seem correct too), but still I'm not having any success sending mail. I also tried removing the account and created it newly - to no avail.

Am I the only one or does anyone else still encounter this problem too or maybe has another hint for solving this issue?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by naytsyrhc
close date 2014-02-06 10:55:46.563907


This would be a duplicate of this, but that question is also closed and states fixed allthough I think it isn't.

naytsyrhc ( 2014-02-06 01:35:25 +0300 )edit

Do you use a different password for outgoing mail? If you do, redo your outgoing mail password. This was a problem for me initially. It's like the Jolla assumes the incoming and outgoing are the same, despite inputting differently. Also, be sure to check the very bottom and select 'password' if you're using authentication.

Spam Hunter ( 2014-02-06 03:51:14 +0300 )edit

Checked both. Have plain Password and typed the password/username once again. Still the same.

naytsyrhc ( 2014-02-06 07:49:54 +0300 )edit

@naytsyrhc - Can you collect the logs ?

If you have developer mode enabled, in


enable file log and add a path for the log, like for example:


Reboot the device and recreate the account, send me the log file to mail-logs at jolla dot com. After that turn file log off again by setting "enabled" to 0.Thanks a lot!

VDVsx ( 2014-02-06 08:47:47 +0300 )edit

Sending with GMX works fine for me since, with the following settings in the outgoing server settings: Username = Kundennummer (login to GMX web mail, on the left lower site "Mein Account", the top box contains the 'Kundennummer'); Password = your password; server = smtp.gmx.net; Secure Connection = SSL; Port = 465; Auth = Password.

Kontio ( 2014-02-06 09:23:59 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-02-06 10:55:26 +0300

naytsyrhc gravatar image

Ok, issue solved. I didn't recognize, that the mail always tried to send from the other - not properly configured - account. I got an email from Jolla with this content:

yes, but you are sending from this account which is broken(authentication is expired), you can disable the email service for this account if you don't use it: Settings-> Accounts-> Google account deselect the email option there.

As per the gmx account I see that it connects perfectly fine, so in the email composer make sure you are sending from that account, you click in the 3 dots on the right side near subject field to expand the view and select the "From" account.

Best regards,


Disabling the not configured account solved the issue. Thanks. And sorry for that "stupid" question.

edit flag offensive delete publish link more


How did Jolla get those info, did you send them some logs?

Sthocs ( 2014-02-06 12:33:56 +0300 )edit

Yes of course. See comments above. @VDVsx ask me to send log to mail-logs at jolla dot com and I did that. Got an answer via mail (quoted above). No magic ;-)

naytsyrhc ( 2014-02-06 12:41:42 +0300 )edit

Question tools



Asked: 2014-02-06 01:33:30 +0300

Seen: 601 times

Last updated: Feb 06 '14