Ask / Submit
0

bash autocompletion not working

asked 2014-02-07 17:14:13 +0200

vbregier gravatar image

When I hit [tab] key in my fingerterm, I expect bash to autocomplete the current command line. But instead it just inputs a tab character.

If I devel-su, then autocompletion works fine.

Anybody has the same problem ? An idea how to fix this ?

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
1

answered 2014-02-07 17:35:45 +0200

If there is more than one possible completion, you have to hit TAB twice to get a list of possible matches.

Other than that, TAB works fine on my phone (1.0.3.8) as a normal user.

edit flag offensive delete publish link more

Comments

Yes, but that is not what was happens on my phone: hitting [tab] inserts a \t character on the command line, which should not be the case (you have to do [ctrl][v] - [tab] to input a tab on the command line.

Maybe this had to do with my .inputrc, since it works correctly now that I disabled POSIXLY_CORRECT var, thanks to #5561.

vbregier ( 2014-02-07 18:38:15 +0200 )edit
1

answered 2014-02-07 18:32:41 +0200

vbregier gravatar image

After a little more research, I found out that #5561 provides a workaround that corrects this problem (along with .bashrc not sourced and start working directory / instead of $HOME).

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-02-07 17:14:13 +0200

Seen: 163 times

Last updated: Feb 07 '14