We have moved to a new Sailfish OS Forum. Please start new discussions there.

[Fixed in] How to Disable Calendar/Contacts Sync? [released]

asked 2014-02-10 00:48:00 +0300

updated 2014-03-28 00:19:58 +0300

I have noticed there is a Google calendar sync entry appearing in sync history and I have read in other questions/comments that there is a one way sync going on. Does this "one way sync" mean that data is only retrieved from added Google accounts and never sent back? Does this one way sync include contacts?

Either way, I am not a fan of syncing contacts, nor calendar entries. Is there any way I can disable any kind of syncing for my simple (NOT Google) email accounts except for mail or tweets? I DO NOT have a Google account added, they are added as simple Email accounts.

EDIT: The attached screenshot shows the sync I am referring to and which I would like to disable. Long-tapping the sync entry shows a Remove option. Which account does this sync refer to and how can it be disabled?

Tapping on Remove shows the remorse timer for removing the "sync endpoint". After being removed, the entry reappears in approximately 24 hours. Remorse timer mentions a 'sync endpoint'

LEDIT: The second screenshot shows one of my Email (NOT Google) accounts added for a GMail address. This is possible and should be possible if I do not want any of the other Google "services" or integration functional on my phone. This is a simple Email account added with GMail credentials.

FINAL EDIT: I can confirm that the described issue has been fixed after the update to Before the update, in multiple tests, I could not make the calendar sync entry disappear from Transfers while a generic e-mail account (with Google) was used. I am happy to see more and more improvements in each update and looking forward for the next ones. Thank you to all who helped on this issue.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by Drekkarian
close date 2014-03-28 00:20:51.319037


I would really like to know which kind of accounts setup you have to enable that sync notification. How is it possible for gmail setup as external email to also sync calendars!?.

foss4ever ( 2014-02-10 17:02:30 +0300 )edit

I am basically asking the same thing. Without adding a Google account and having only Email accounts with Gmail credentials, why is there a Google Calendar Sync going on?

Drekkarian ( 2014-02-10 17:49:58 +0300 )edit

Why is your question still talking about Contacts sync? You have only shown a screenshot of calendar sync event..

foss4ever ( 2014-02-10 18:39:44 +0300 )edit

And Gmail is just Google mail, and when you define Google acc in Jolla and disable all other services than email you IMO get the exactly same setup as defining external email acc connected to Google email server URLs.

foss4ever ( 2014-02-10 18:43:05 +0300 )edit

Besisdes, I have tried both setups with Google and Gmail as extetnal acc, and I have never got such a sync notification even if my Calendsars where synced (one-way) from Google to phone (when Google acc setup had sync enabled).

foss4ever ( 2014-02-10 18:46:16 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2014-02-10 03:26:09 +0300

dmelamet gravatar image

Sure! Go to Settings, Accounts, there under each account (Google, Exchange) there is an option to sync or not to sync different kind of data. Exchange is very detailed, while Google gives you the option Sync, which includes "contacts and other details". Try that one...

edit flag offensive delete publish link more


Thanks for your answer, but there is no sync option to disable for google email accounts. The added account is a generic email account, configured with gmail. The only option available is for sending and receiving email.

Drekkarian ( 2014-02-10 09:41:33 +0300 )edit

In your question you talk about Google account sync that's why you get answer to that. That's how I also.understood your question because you don't mention that rhis is actually abt external mail account (which is a strange setup cause you get gmail sync by setting up Google account and just disabling all the other check-boxes in acc setup, as pointed out in this answer).

foss4ever ( 2014-02-10 16:58:40 +0300 )edit

answered 2014-02-11 08:58:36 +0300

VDVsx gravatar image

Google calendars and contacts are not synced when using a Generic email service for Gmail, you can also create a Google account and disable the "Sync" option in order to not sync calendars and contacts. Sync history normally shows syncs done between devices.

edit flag offensive delete publish link more


Thank you for your answer. It's nice to see an official reply :) I am happy to find out that there should not be any sync for generic emails. Now all I need to determine is why I see this behavior on my phone and how I can stop it. I have 3 emails accounts configured with GMail addresses. I will try to delete them and add them back one by one. It will take me a few days to see the final outcome, as the sync only happens once per day.

Drekkarian ( 2014-02-11 11:06:41 +0300 )edit

It can be actually a bug, but a false positive in this case, nothing is synced, but the plugin emits success when no account is found, created a internal report for investigation.

VDVsx ( 2014-02-11 11:27:36 +0300 )edit

That's what I tried to explain in my replys to @Drekkarian that such a setup shouldn't cause Calendar and/or Contacts sync. And if it happens it must a strange bug cause such a behaviour hasn't been reported by anyone else.. Good that the expected behavior has now been confirmed by Jolla, and at same token I'm sorry if my attempts to diagnose and analyze this haven't been helpful. It is just difficult to imagine what might be the root cause when I haven't been able to reproduce this behaviour with my own Google/Gmail setups.

foss4ever ( 2014-02-11 14:22:36 +0300 )edit

And the second part of this Answer is the same as given by @dmelamet previously (see below). But, if there are some intetnal issues in the sync behaviour then it's better that those be sorted out by those who can ;) rather than community trying to guess what's going on..

foss4ever ( 2014-02-11 14:32:05 +0300 )edit

@VDVsx: Thank you for your help. I'll post here if I have any updates on this issue.

Drekkarian ( 2014-02-11 14:34:10 +0300 )edit

Question tools



Asked: 2014-02-10 00:48:00 +0300

Seen: 762 times

Last updated: Mar 28 '14