Ask / Submit
15

Automatically show hotspot captive portal login page

asked 2014-02-10 10:51:36 +0200

hzdjolla gravatar image

updated 2014-05-17 02:45:27 +0200

chemist gravatar image

Jolla doesn't show login page when I connect to hotspots, unlike iPhone. Apparently there is no detection that Internet access is restricted and HTTP requests are being redirected. I have to open a browser and try opening some webpage so that I get redirected to the hotspot's captive portal login screen.

edit retag flag offensive close delete

Comments

And I was clueless initially on how to connect till I accidentally opened browser to check if google.com is working!

anandrkris ( 2014-12-10 15:23:48 +0200 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2014-05-17 02:38:28 +0200

tigeli gravatar image

There is a logic, but there are also problems with it. Eg. if you have mobile data enabled simultaneously the device will keep using mobile data instead of opening a browser, but we are working on this to make it better.

edit flag offensive delete publish link more

Comments

So if mobile data is disabled captive hotspot detection would work? Is there a way to disable mobile data completely - I only found a way to force 2G?

hzdjolla ( 2014-05-17 12:39:50 +0200 )edit

@hzdjolla you toggle the mobile data switch in the Mobile network settings page off. Mobile data should still work in 2G mode albeit very slowly.

Aaron McCarthy ( 2014-05-19 09:46:18 +0200 )edit

I don't see an option to disable mobile data specifically... In my Mobile network settings I only have the following options:

Contract : disabled, Data roaming : Do not allow, MMS access point, Network mode: only has options 3G/2G, Select network automatically

hzdjolla ( 2014-05-19 13:34:48 +0200 )edit

@hzdjolla "Contract" (under the mobile data section) is the name of the mobile data APN used to connect to the internet with you plan/mobile carrier. It is a toggle switch specifying if mobile data is allowed to be used automatically or not. The "disabled" text indicates that it is currently off (mobile data will not be used). The indicator to the left should also be dim.

Aaron McCarthy ( 2014-05-19 15:14:03 +0200 )edit

@aaron-mccarthy OK I had "Contract" disabled already, so switching off mobile data doesn't help. I must say that "Contract" setting is very confusing and there is no explanation for it. In my case I have a very low limit of data per month, so I always want to confirm data use, even though I have a contract.

hzdjolla ( 2014-05-19 22:35:32 +0200 )edit
0

answered 2014-02-10 12:24:40 +0200

This is very close to: https://together.jolla.com/question/6013/roaming-client-for-international-wifiwlan-hotspot-roaming/ where there has already been discussion on how this could be implemented in Jolla.

edit flag offensive delete publish link more

Comments

I disagree. That topic is about hotspot roaming using WPA etc, I didn't see anything about captive portal screen appearing automatically.

hzdjolla ( 2014-02-10 13:57:47 +0200 )edit
2

Just to make it clear on how other phones like iPhone decide that they are on a captive portal hotspot:

  1. Make an HTTP request to some predefined website controlled by the OS maker.
  2. Verify that the response is what is expected.
  3. If response does not match expectation, then we must have been redirected to a captive portal. Phone proceeds to show the response it received.
hzdjolla ( 2014-02-10 14:06:06 +0200 )edit

I'm reopening this question since question 6013 refers to a roaming client, while here we speak about simple captive hotspot portal detection and automatic opening of its webpage. Currently Sailfish is unable to detect captive portals in any of hotspots provided by three major telco operators of my country. Logic of how it should be done is described above.

hzdjolla ( 2014-05-17 00:43:26 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-02-10 10:51:36 +0200

Seen: 1,371 times

Last updated: May 17 '14