Ask / Submit
85

bug: Jolla app icons "rearranging" by itself

asked 2014-02-10 13:24:43 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2015-06-29 12:26:19 +0300

molan gravatar image

The device was connected to charger last night and switched off. When opening phone in the morning, I noticed the native default Jolla apps (calendar, clock, mediaplayer, notes etc.) had rearranged by itself to different positions that I had set these before. Also the factory installed defaults like jolla store and gallery had moved to original factory installed position.

Most default apps were set on the first app page, but these apps had now moved to the second app page by itself without me rearranging them (After reboot on being charged overnight).

Rearranging apps to the original positions by dragging is not a big problem, but it should not likely happen and is to be considered a bug. Is there a fix coming soon for this?

STATUS: Jolla tracking the issue (September 2014)

[UPDATE 29.06.2015]: Unfortunately still happens with SailfishOS 1.1.6.27.

edit retag flag offensive close delete

Comments

1

I've had the same issue with all app icons spontaneously shuffling positions for no apparent reason. Happened to me twice (with 1.0.2.5 but I don't think that's meaningful in this case).

typo ( 2014-02-12 21:22:39 +0300 )edit
2

Yes, I had it too on 1.0.3.8. Quite annoying...

rob_kouw ( 2014-02-15 09:51:46 +0300 )edit
1

Here too, has happened to twice. Once on 1.0.3.8 and once on an earlier firmware.

jjhuopa ( 2014-03-17 08:09:39 +0300 )edit
1

Seen this too. No idea what causes it.

JarnoF ( 2014-03-17 15:08:21 +0300 )edit
4

So this started happening after 1.0.4.2 update, app icons getting randomly re-arranged. Quite disturbing

jorkkila ( 2014-03-18 20:18:45 +0300 )edit

7 Answers

Sort by » oldest newest most voted
14

answered 2014-03-26 11:49:29 +0300

updated 2014-04-24 01:59:28 +0300

I searched around at least to know which behaviour causes it and I have a beginning o f answer.

It happens on my Jolla each time wifi network is not detected or not automatically connected and I use pulley menu in Wifi parameters menu.

Green LED blinks very quiclky and then layout launcher is resetted. Can someone else confirm this behaviour too?

EDIT: I found a temporary solution even if it is not really one. I just don't force wifi to connect anymore (pulley menu in wifi menu). Since I stopped this, it didn't happen anymore.

edit flag offensive delete publish link more

Comments

4

It happened to me once, app icon reshuffling happened while I was trying to recover from a lost wifi connection. I think the phone was not able to detect AP, connection was lost overnight for some reason.

pmelas ( 2014-03-26 12:07:58 +0300 )edit
3

I can confirm it,yesterday happened twice. I also noticed that happened when the phone had long runtime, 5 days or more, and Android runtime didn't work anymore. The number of running processes dropped from about 600 to less than 500, with everything closed. A reboot was needed in this situation.

magullo ( 2014-04-02 08:48:49 +0300 )edit

Last week, I encountered this behavior (Green LED blinks very quickly and then layout in launcher is reset) for the first time. Even with the newest Firmware 1.0.5.15 the problem seems still to exist. Also for me it had something to do with WIFI. I bought a new WLAN router (AVM FritzBox) and when the Jolla phone connected the first time to it, the problem appeared.

KRM ( 2014-04-24 13:05:47 +0300 )edit
1

Happened to me yesterday, on tahkalampi firmware.

Didn't notice anything with the Wifi, and nothing had changed. But the screen went black and the green led flashed fast before returning to normal. I mostly have the launcher set to default so I didn't notice any changes there

r0kk3rz ( 2014-09-04 18:38:51 +0300 )edit
2

The green led blinking points to the homescreen not responding/restarting. Why this might cause the icon to rearrange I still have no idea.

stezz ( 2014-09-05 09:34:35 +0300 )edit
14

answered 2016-01-12 14:40:44 +0300

erinmore gravatar image

updated 2016-02-08 13:40:12 +0300

The problem still seems to persist as of January 2016 (Sailfish 2.0.0.10). I also noticed that it always forgets my location in the "Weather" app. Do you know if there is any way of backing up/restoring the folder layout?

Update(08/Feb/2016) -- The problem occurred again. This time, the wi-fi was on and I opened the Jolla Store app when the device showed the "app registry error" warning, followed by a blank screen. When I resuscitated my phone back to life, all the apps were already misplaced and folders gone. Any ideas?

edit flag offensive delete publish link more

Comments

7

Yep this happened for me too with Sailfish 2.0.1.7. Phone was connected to charger and in the morning all apps folders were gone. Didn't find any other solution than rearrange apps again manually... I thought that because phone is already over two years old it starts to brake down but I quess age is not the case.

japsi ( 2016-01-25 10:41:24 +0300 )edit

@erinmore thsi strange process seems to happened fast. I loose a contact entry done for 2 days ago too.
What i remarked too, is that some sync tries or event are done, even if the connection to sync accounts are not connected.

cemoi71 ( 2016-03-16 13:53:36 +0300 )edit

@japsi no no , the age is not the case. and that is funny, but it happened with all the software versions that i had.
and every time that the arrangement disappears i'm now sure that i noticed few weeks or days that i missed a calendar or contact entry. I'm not sure if it is bound, or is an hazard, but i noticed it.

cemoi71 ( 2016-03-16 13:58:22 +0300 )edit

happened one time to me with 1.1.9 or 2.0.0 and one time again with the 2.0.1.7.

mettska ( 2016-03-16 13:59:17 +0300 )edit
13

answered 2014-09-04 09:33:34 +0300

stezz gravatar image

Thanks for the report. We are now tracking this internally.

edit flag offensive delete publish link more

Comments

I had this problem today as well. Green blinking, all apps closed, screen locked. I unlocked the screen and the grid was fine. I was annoyed a bit by the behaviour and manually restarted the device, but after the rebot the grid was messed up. all android apps first, jolla standard aps (mail, maps etc) at the bottom.

I didn't had turned wifi on, only mobile data. I was in the train, bad connection, disconnects to 3G network.

fingers crossed and good luck for the bug hunt.

prometoys ( 2014-09-21 17:10:18 +0300 )edit

Same here just happened now. Green lights blinking fast - had to reboot phone and afterwards all my folders were gone and icons rearranged. Since I was traveling with the train and switching between 2G/3G as well as WLAN, it is very well possible that switching between connection caused this crash (like @juju_des_highlands reported here).

molan ( 2014-10-18 15:01:51 +0300 )edit
1

Happened to me as well, just now. Was trying to connect to wifi. What happened was that gps and 3G switched on/off opposite to wifi. After a reboot icons were back to default locations and folders gone. v1.0.8.21, approx 700MB free disk space.

pfbach ( 2014-11-28 19:13:09 +0300 )edit

I have the exact same problems.

Green blinking, no network connections, rearranged starters.

It is 1.1.27.

I have had a full disk a few weeks before, deleted a few mp3s, no more problems..

BTW. Why is /home the same disk as / ?

UPDATE After a reboot everything is at its place again. Network is working etc.. thats no behavior I expect from a Linux device.. :|

Tiggez ( 2015-01-09 17:46:17 +0300 )edit

Just teporting this re-arraning of icons in Launcher has never happened in my device that I've been using since the first OS version a year ago until the current 1.1.1.27. During this time naturally the 3g or WLAN connections hace many times been unavailable, unreachable, disconnected and/or reconnected, but the Laumcher icons have stayed where I have positioned them. And very rarely have I seen the green or red light started to blink in normal use and the device has rebooted but no change in icon positioning has resulted. For those who are affected, I hope you find out what causes this, and get it fixed. Very strange bug, indeed :/

foss4ever ( 2015-01-09 19:17:42 +0300 )edit
4

answered 2016-04-22 02:03:57 +0300

Crypto gravatar image

Hi Guys,

I have had this problem and it still happens with the latest version. If you notice this happen on your device, immediately turn it off by holding the lock button for 5 seconds. Don't go through the shutdown menu.. when it restarts, everything is arranged again. If you use the restart/shutdown funciton, it seems to save this state and you are screwed until you rearrange it

edit flag offensive delete publish link more

Comments

3

Will try this the next time it happens and will report here.

Jordi ( 2016-04-22 08:35:42 +0300 )edit
1

interesting thing. i'll do it too.

cemoi71 ( 2016-04-22 11:12:03 +0300 )edit
1

ffect happens again today, but the trick didn't work for me :-(

cemoi71 ( 2016-05-04 15:01:21 +0300 )edit

Same here, the trick didn't work for me either. Let's go for 20-30 minutes of rearrangement...

Jordi ( 2016-05-13 19:46:09 +0300 )edit

The bug hapened twice since May 13 and that trick did not help. We need to find something, this bug is a real PITA.

Jordi ( 2016-06-07 11:39:01 +0300 )edit
2

answered 2015-01-20 14:25:47 +0300

smirta gravatar image

I have the very same behavior since the last release 1.1.1.27. I've lost at least two times my apps list settings. All the groups are gone and I can't figure out how the apps are ordered afterwards. This always happened after a reboot. The last time was today morning. This time I've noticed that the phone is blinking green and seemed like the UI is rebooting. And after it didn't stop to blink and reboot all over I've restarted the device which lead to lose all groups/settings. Before 1.1.1.27 I've never had such a problem.

Where should I start to debug? I don't really know journalctl and I didn't succeed to get valuable information out of it. This kind of log display as it is in journalctl is either shit or I did not yet find the right way to use it.

edit flag offensive delete publish link more

Comments

1

Happened this morning with 1.1.2.15 (Yliaavanlampi). After reboot (due to missing ambiences) all apps were back at default positions, and all app folders were gone.

tibes ( 2015-02-25 09:24:17 +0300 )edit

For me, this has happened mostly with 4G on... not with 3G, except pre-Yliaavaanlampi sometimes when using the Tidings apps & surfing with its internal web browser mode for an extended period on the Slashdot site (phone got quite warm).

Somehow, at least when using 4G preferences, the phone doesn't like it when connections switch a lot or go bad - the phone seems to freak out then with the blinking green led-flashes and quick reboots - then you know you're in for trouble :)

Whatever the cause - NO fault should EVER mess with the order of apps I have determined, or the folders I have created. That is simply inexcusable, the OS should NOT EVER be able to change what I have told it to do...

ultraboy ( 2015-03-30 22:39:55 +0300 )edit
2

answered 2016-03-16 13:34:36 +0300

cemoi71 gravatar image

updated 2016-05-04 15:27:35 +0300

I have SFOS 2.0.0.10
And I had this issue on the 9.03.2016, but the phone didn't crashed.
It seems that happened on standby and looked like the same as an initialisation behaviour one.
Some background application were closed, and service too.

Before the event, the wifi was on (but i'm not sure if it was still on after it).
All the app-folder are gone, and i miss one contact entry created 2 days before.

I think it is bound to the wifi too, but have a strong feeling with that it is bound to the sync interface too.
Because of this strange behaviour, that sfos do some sync actions with my accounts anyway, even if if the account is closed.
All my accounts were and are currently not connected all the time.
Is it programmed that google should not sync any-more (just mails), and have besides a carddav/caldav server where the communication don't works on jolla side. That's why they are all closed.
But why this contact has disappeared? Is it a clue for the problem?

All happened fast. It was a matter of seconds. Between i switched the display from off, to on. The changing was so obvious, then.

Edit 4.05.2016:
I'm still with sfos 2.0.0.10, and this strange effect happened again.
Then i remarked before it happens, that i would forget the wlan to plug-off over the last night.
Then today on midday, i realized by activate the display, that the Camera app displayed a black screen instead of the object i aimed.
And after a little while, sfos wanted to close the app because it not answer.
I did it three times (open camera, then close because black, and sfos wanted to close it).
Then, i tried to use the utility to restart the welcome screen "useful if an app is blocked".
Then tried to open the camera app again. Was still black, sfos still wanted to close it after a while, but a notification came and informed that the store has some errors.
Then i go not further, that made by me like a click: it happened again!!... and noticed that all my app folders has disappeared...
And directly hold the shut-down button more than 5s. But didn't help to retrieve them by next start...

edit flag offensive delete publish link more

Comments

1

on 2.0.1.7 - similar issue since the update (never before) the only effected icon is the calendar which is moving to tbe very last position several times a day - no wifi no charger no crash ...

elastic ( 2016-03-21 10:21:14 +0300 )edit
1

@elastic: Do you use the calendar patch that updates the date on the icon? If yes, then this is the problem for the moving. Happens by me too, but strangely after a couple of days it doesn't move anymore it stays where I put the icon

PatsJolla ( 2016-03-21 11:24:45 +0300 )edit

@PatsJolla yes I have installed that patch - thanks for the hint - it might be possible that it alsways moves when the icon is changed to a special day - I'll observe the behaviour the next days (there should be a few changes to the icon on the Easter days ;-) )

elastic ( 2016-03-22 13:04:30 +0300 )edit

I have the same behaviour, only the calendar icon moves. Not sure whether that happens since I installed the patch or if it started before. However I can confirm that changing the icon does not necessarily move it to the bottom of the apps grid. I do have some periods of several days where it doesn't move. Haven't got a clue what could cause the movement.

jollajo ( 2016-03-22 16:14:00 +0300 )edit
1

@cemoi71 do you use any patches / extensions etc?

When you said that a contact entry vanished, do you mean a contact from People app? Did you add it manually on the device, or was it synced from elsewhere?

chris.adams ( 2016-03-24 14:18:18 +0300 )edit
1

answered 2015-04-16 12:17:07 +0300

PatsJolla gravatar image

updated 2015-04-16 12:20:00 +0300

This happened today to me too. For the first time ever, although I had already quite many crashes of the phone and the launcher so far. The phone was not on the charger and roughly with 60% battery still. It must have happened during the night so I can't really tell what was the behaviour at that moment. In the last 3 weeks though I have repeatedly crashes (green LED blinking with restarting the launcher) and extremely often I get the message "Problem with the App-Store/App-Registry" usually I then use the reset function in the utilities-app but I'm never sure if it actually works.

I'm running version 1.1.2.16.

Would be nice to get an info how we can avoid this. This effect or bug is extremely annoying. Are there some log files we could create?

edit flag offensive delete publish link more

Comments

So I had this phenomenon running version 1.1.4.29 besides the already described symptoms, the app "Weather" (also showing the weather in notification view) lost the configured locations.

xllndr ( 2015-05-07 11:04:21 +0300 )edit

Had the same problem yesterday, during day, without any special incidents beforehand. Latest OS version running. Had a crash on the weekend so the device was rather freshly started.

Additional to all app icons rearranged and folders lost the weather app lost its settings, too.

Alex-S ( 2015-05-12 10:00:34 +0300 )edit
Login/Signup to Answer

Question tools

Follow
11 followers

Stats

Asked: 2014-02-10 13:24:43 +0300

Seen: 2,296 times

Last updated: May 04 '16