We have moved to a new Sailfish OS Forum. Please start new discussions there.
13

Proximity Sensor Problem

asked 2014-02-13 14:15:53 +0200

strongm gravatar image

Quite often my Jolla activates the touchscreen when I'm on phone call, meaning that my ear presses random buttons (such as Loudspeaker) whilst I'm in the middle of the call.

Does anyone else experience this, or do I just have a duff proximity sensor?

edit retag flag offensive close delete

Comments

The sensor position is pretty perfect, I have a tod smaller ears than average and the sensor hits my ear pretty good, also it activates at >1cm distance already. Are you sure you do not press a button by accident by changing your way of holding while on a call? I crank it on my shoulder to have my hands free sometimes and I haven't pressed any buttons yet. @CsTom this is about calling... the other is about pocket activation problems...

chemist ( 2014-02-13 17:49:08 +0200 )edit

...which again boils down to the "switch off the touch when the proximity is triggered". :-P Yes, I also did put on hold calls by my ear, which shouldn't happen if the proximity sensor would be handled at all.

CsTom ( 2014-02-13 17:59:58 +0200 )edit

Are you sure you do not press a button by accident by changing your way of holding while on a call

Absolutely sure.

strongm ( 2014-02-13 18:04:53 +0200 )edit

Tried around for a bit and it is actually turning of the whole screen including display and touch-screen from a distance of approximately 2cm in <500ms, if it does not do that it is a bug (or a hardware fault) you can just test it flat on a table calling home or something and hover your finger 1cm above the sensor, try with and without apps (fresh after boot)! If not that, you have a funky way of holding your phone & you should probably change your habit... (my ear to sensor dist is <5mm so WFM)

chemist ( 2014-02-13 18:30:08 +0200 )edit

2 Answers

Sort by » oldest newest most voted
5

answered 2014-02-13 14:28:20 +0200

Nicolas gravatar image

I have the same problem. The Jolla should be faster in disabling the screen when detecting proximity, and it should wait a bit longer to enable it back when stopping to detect proximity (the timing on my Nokia 5800 was perfect!).

Also, the sensor is very far away (more than 2 cm) from the speaker. It should definitely be placed closer in a next hardware iteration.

edit flag offensive delete publish link more

Comments

While I hate to just say "Me too", I have no other option to do so. Me too.

Mostly it happens, when I switch the phone from one ear to the other.

Venty ( 2014-02-13 15:17:44 +0200 )edit
3

answered 2014-03-05 08:53:04 +0200

spiiroin gravatar image

Changes to this are in the plans. In addition to timing of proximity change handling, also the relatively long time it takes to make a display off-on-off cycle and the way touch input gets enabled during off-on transition plays a role in here.

edit flag offensive delete publish link more

Comments

Just thought I should now comment that I have not had a recurrence of this issue since the 1.0.5.16 update

strongm ( 2014-04-23 01:38:09 +0200 )edit

@strongm Glad to hear that. Related changes in 1.0.5.16 update were: hysteresis was added to proximity blanking - blanks on covering, must stay uncovered a while before unblanking -> nothing happens if proximity sensor is uncovered briefly; if finger/palm is detected on screen when unblanking, touch input is blocked until touch release -> even if display does come up, no input gets through if it is blanked again. Some fine tuning still to be made in the future updates.

spiiroin ( 2014-04-23 11:08:01 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-02-13 14:15:53 +0200

Seen: 573 times

Last updated: Mar 05 '14