We have moved to a new Sailfish OS Forum. Please start new discussions there.
6

wlan (wifi), mobile data & battery management

asked 2014-02-20 06:24:28 +0200

flynx gravatar image

updated 2014-03-11 00:16:33 +0200

Not sure if here or tmo is the best place for this question... but here goes.

I still use an N900 and I am trying to migrate over to my Jolla. One of my favorite features of the N900 was that it could be configured to automatically connect to every available network (both mobile and wifi) and stay connected all the time. Battery life suffers but that isn't important to me. Always being connected IS important to me.

I am aware of the connectivity bugs we have right now. But also my Jolla seems to disconnect from wifi when it isn't needed (i assume to save battery). Can it be made to stay connected all the time, or if it is disconnected to constantly search for another network until it finds one or the battery dies?

When I first turn my Jolla on, it asks me which connection I want to use. What I want is for it to use them all without asking.

edit retag flag offensive close delete

Comments

2

I have the same issue for 3G connection: unless I keep skype open, the 3G connection is dropped and often Jolla can't succesfully reconnect to 3G (connection icon with ! in between)

c.la ( 2014-03-11 10:32:19 +0200 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2014-02-20 06:47:03 +0200

ovekaaven gravatar image

updated 2014-02-20 07:23:59 +0200

I'm not sure it disconnects intentionally, I suspect the connections just time out. See, unlike the N900 and N9, the Jolla completely shuts down the main CPU when the phone is not in use (just like Android phones do). That means that stuff like connman doesn't get to run at all, and therefore, it can't keep connections alive. It's possible to make the CPU power up periodically, and some apps do, but I'm not sure Jolla is interested in doing it just to let connman keep unused connections alive.

You can prevent the CPU from completely shutting down by doing something like

echo asdf > /sys/power/wake_lock

(see: http://talk.maemo.org/showthread.php?t=92183)

edit flag offensive delete publish link more

Comments

Thanks for this. At first glance, it appears to have the intended affect. top continues to run in ssh when the display is powered off. The change doesn't survive reboot.

flynx ( 2014-02-20 22:21:13 +0200 )edit

Maybe there is a sysctl equivalent for Mer/Nemo/Sailfish to make this kind of setting permanent ? (pkcon install sysctl did not work for me).

alci ( 2014-03-11 09:54:22 +0200 )edit
2

thank you for this insight. Can't Jolla use just one (underclocked) core for background operations?

c.la ( 2014-03-11 10:33:25 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-02-20 06:24:28 +0200

Seen: 410 times

Last updated: Mar 11 '14