We have moved to a new Sailfish OS Forum. Please start new discussions there.
9

Bug: no SMS to networks abroad

asked 2014-02-22 17:02:30 +0300

rafaelino gravatar image

updated 2014-12-06 00:34:43 +0300

pulsar gravatar image

Hi,

No-one else seems to have reported this problem, so here goes...

  • My telco is Deutsche Telekom
  • SMS within Germany works fine
  • SMS to any network abroad shows "Problem with sending message"
  • Problem only appears on my Jolla. Plug the SIM into an iPhone: works like a charm

Conclusion: something must be wrong in the automatic SMS configuration. I checked Settings -> Apps -> Messaging: the SMS message centre address seems to be correct (as shown on homepage of Deutsche Telekom: +491710760000).

So what is happening here? Is there a log somewhere (/var/log?) where I can get a more expressive error message? Anything at all?

I could call the telco, but knowing support hotlines I fear I'd have to explain to them first what a Jolla is, then work past the "we-only-support" stage, only to hear it's my problem.

Thanks for any assistance.

edit retag flag offensive close delete

Comments

Same problem here, switched from O2 multiSIM (where SMS to abroad worked just fine) to Telekom multiSIM.

WRT logs journalctl is your friend. I get this

[root@Jolla ~]# journalctl -f
[...]
May 04 12:19:56 Jolla ofonod[841]: not allowed by MO SMS control, do not retry
[...]

WRT support, the Nokia N9 is on their list of supported devices, I hoped that the Jolla parses config messages for the N9. But after using this answer and rebooting the phone (as told to by the message after config was received), no improvement.

EDIT: What did help was to read this. When sending the UMS code for status I was shown 'messaging not enabled'. Sending *222# made the error in the journal no longer appear and an SMS sent to a number abroad report delivery.

[EDIT: cleanup as solution that works for me found. Will post separate answer momentarily.

pcfe ( 2014-05-04 13:40:31 +0300 )edit

I have a similar problem. Sending messages to a number abroad I get "Problem sending message" and journalctl shows

dbus[467]: [system] Rejected send message, 5 matched rules; type="method_return", sender=":1.13" (uid=0 pid=841 comm="/usr/sbin/ofonod -n --nobacktrace --noplugin=he910") interface="(unset)" member="(unset)" e rror name="(unset)" requested_reply="0" destination=":1.14" (uid=0 pid=849 comm="/usr/bin/fastdormancyd ")

My operator is Halebop/Telia (Sweden).

luen ( 2015-02-25 23:35:33 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-04 18:41:33 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-05-07 15:24:42 +0300

pcfe gravatar image

What do you get when requesting messaging status with *221#

If you get a message to the effect of 'messaging disabled', try sending *222#

For me this has helped, I have done the following successfully

  • SMS from Germany to a German number
  • SMS from Germany to a non-German number
  • SMS while roaming to a German number
  • SMS while roaming to a number in the roaming country

references: t-mobile help pages

edit 2014-05-07: added the tests I have run since changing the setting.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-02-22 17:02:30 +0300

Seen: 383 times

Last updated: May 07 '14