Missed call from private number doesn't show up in Events view. [released]

asked 2014-02-24 16:49:14 +0200

updated 2015-06-30 12:39:22 +0200

raketti gravatar image

Today I know I should have received a call from a hidden number. When the phone rang I didn't hear it immediately due to traffic sounds around. When I checked the phone the call had already ended, but the phone didn't indicate I had received a call. As I wasn't sure I received a call, I concluded I hadn't. But when I came home my wife said she tried to call me from work (hospital have hidden numbers in Finland), but couldn't reach me.

In other words, there seems to be a bug. But it would be good to get this confirmed as who knows... perhaps there was some other problem that I couldn't receive the call.

EDIT: Changed title to use 'private' instead of 'hidden'.

EDIT: Added screenshot: Incoming call, Call log, Events view

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by molan
close date 2017-02-09 18:04:55.659025


I am OK to be not bugged about a missed call I cannot associate anyway. OTOH other cases like yours are a different story. So if it is a feature, it could be made optional.

Blizzz ( 2014-02-24 17:26:28 +0200 )edit

@Blizzz well no. A missed call is a missed call, irregardless of the caller ID visible or hidden (IMHO). All the phones I owned reported all missed calls. It looks like a bug here.

c.la ( 2014-02-24 19:17:17 +0200 )edit

That sounds weird: on Feb 16 I received 2 calls from a private number (I guess it's the same as a hidden number), I missed them and I got them notified (they are still present in my call log). Just don't remember whether they were notified in the lock screen too or just in the notifications screen. Of course I've been using Sailfish OS v.

Gianluca ( 2014-02-24 19:18:14 +0200 )edit

I suggest: Check it yourself and try to verify the circumstances. Usually, there is some call-by-call code or setting for the calling phone to enforce the number to be hidden (mobile and landline phone alike).

I just did it: The call is notified and listed in the phone log ("Private number").

jgr ( 2014-02-24 22:11:21 +0200 )edit

I hadn't thought of checking the call log. It definitely shows 'private number' in the call-log, so the only issue is that it didn't show I had received a private call on the lock/notification-screen.

avdwoude ( 2014-02-24 22:50:08 +0200 )edit