Ask / Submit
1

[bug] Browser tab window graphics bug

asked 2014-02-25 23:06:44 +0200

Puu gravatar image

updated 2014-02-25 23:07:08 +0200

I've been having huge stability issues (like crashing consecutively after gaining connection to network etc.) with my Jolla and decided to do a factory reset. The stability issues are still there but another bug rose up the reset; my browser tab window is all scrambled up like this: Scrambled browser and another shot. I tried doing another factory reset to see if the issue would go away, but the problem stayed (and the stability issues too...). Does anyone have any clue about this?

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-02-26 11:09:24 +0200

veskuh gravatar image

This happens when you do not have any ambience set. 1) Go to gallery 2) select photos 3) choose an image and tap it 4) tap the image to reveal menu 5) pull down the pulleymenu and choose "create ambiance"

after this the tab view in browser should look normal.

edit flag offensive delete publish link more

Comments

@veskuh Does this mean that it is bug i.e. such condition that ambience picture is not set should not be possible select by the user?

What other possible issues/problems missing unset ambience can cause for user?

Kari ( 2014-02-26 12:04:12 +0200 )edit

@Kari Yes, something has gone wrong if ambience is not set. User cannot just unset it from UI. A developer could perhaps accidentally clear some file that is related or if you would be able to quit tutorial without setting it up would be another possibility.

I'm not sure about other symptoms beside having black background in UI and having messed up tab page in browser.

veskuh ( 2014-02-26 12:28:10 +0200 )edit

@veskuh Should you consider that there is always by default one ambience set i.e. Jolla Default to avoid e.g. the unset of ambience during the tutorial or make the change to tutorial that it would not be possible to quit until the ambience has been set for the first usage.

I remember when I started my Jolla it asked me at some point to select the color - was that color selection actually the primary ambience color selection?

When creating custom ambience with camera picture it creates amber as primary color, which was different than the initial Camera ambience I was using the first weeks.

@Puu you have indicated that you made factory reset i.e. it means you have had to start from scratch again. Can tell us how the initial steps went and were you offered to set the default ambience during the initail setup of your Jolla?

Kari ( 2014-02-26 13:45:55 +0200 )edit
1

@Kari Yes, startup wizard's "favorite color" picker sets the initial ambiance. I agree that for robustness sake we should implement fully working fallback.

veskuh ( 2014-02-26 14:15:21 +0200 )edit

@veskuh Do you think it would be possible allow creation of the custom ambience in such way that primary color would be possible to choose from the list of colors, which would be filtered based on the ambience color selection algorithm?

Alternatively there could be also option to have both primary color selections i.e. from the list or automatically from the selected ambience picture.

Kari ( 2014-02-26 14:30:46 +0200 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-02-25 23:06:44 +0200

Seen: 134 times

Last updated: Feb 26 '14