We have moved to a new Sailfish OS Forum. Please start new discussions there.
5

Moving e-mails in IMAP account only done locally [released]

asked 2014-03-01 22:27:50 +0300

birefringence gravatar image

updated 2014-06-22 21:51:22 +0300

When I move an e-mail from the locally created "Sent" folder to a folder in my IMAP account, this is only done locally. The message is shown correctly in the (server-side) folder on the phone, but this change is never propagated to the server. No error message appears. I can then continue to move the message around, always being shown correctly on the phone, but the message never appears on the server.

journalctl -af says:

Mar 01 21:22:37 localhost jolla-email[1389]: [D] EmailAgent::executeCurrent:919 - Executing  "move-messages-to-folder:message-ids=123;folder-id=5" 
Mar 01 21:22:37 localhost jolla-email[1389]: [D] EmailAgent::activityChanged:368 - Activity State Changed: 0 
Mar 01 21:22:37 localhost jolla-email[1389]: [D] EmailAgent::executeCurrent:919 - Executing  "exporting-updates:account-id=2" 
Mar 01 21:22:37 localhost jolla-email[1389]: [D] EmailAgent::activityChanged:368 - Activity State Changed: 0 
Mar 01 21:22:37 localhost jolla-email[1389]: [D] EmailAgent::standardFolderId:644 - Error: Standard folder  5  not found for account:  2 
Mar 01 21:22:37 localhost jolla-email[1389]: [D] FolderListModel::resetModel:401 - Creating local trash folder! 
Mar 01 21:22:37 localhost jolla-email[1389]: [D] EmailAgent::standardFolderId:644 - Error: Standard folder  4  not found for account:  2 
Mar 01 21:22:37 localhost jolla-email[1389]: [D] FolderListModel::resetModel:411 - Creating local sent folder! 
Mar 01 21:22:38 localhost jolla-email[1389]: [D] EmailAgent::activityChanged:368 - Activity State Changed: 1 
Mar 01 21:22:38 localhost jolla-email[1389]: [D] EmailAgent::activityChanged:355 - Sync completed.

Messages which are already present on the server can be moved properly.

This is kind of annoying, because due to this I cannot move sent messages from the phone to the server ...

Update: (Bump) Also with the latest update (1.0.7.16) there is still no improvement concerning the folder mapping ...

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by birefringence
close date 2014-12-23 21:42:52.032473

Comments

For me, also mails that I delete are deleted on the Jolla but just marked as "read" on the server and never deleted. Do you also have this problem?

paulvt ( 2014-03-02 10:01:08 +0300 )edit

@birefringence - In these logs you are moving messages to folder 5 (trash) that is local only, trash and sent folder are not matched with the server ones so local ones are created. Are you folders exported via IMAP ? What are their names in the server side ?

VDVsx ( 2014-03-03 10:44:09 +0300 )edit

Indeed, the folders are not matched. I cannot fix this, because my e-mail provider (GMX) does not allow me to change the names, and I do not know how to manually match folders on the Jolla. I'm currently thinking about setting up my own server (I was gonna do that anyway ...).

Nevertheless, I would expect that if I move a message from one of the local folders to a folder that exists on the IMAP server, the message is actually moved to the server.

birefringence ( 2014-03-03 19:43:25 +0300 )edit

@birefringence - If you move to a server folder sure will be moved, but as I explained above you are moving between local folders, can you tell me the exact name of the folders in the server side ?

VDVsx ( 2014-03-04 08:50:23 +0300 )edit

I have a folder "Gesendet" on the server (which is German for "Sent"). In the folder list this name appears twice. One is the server folder and one is the local copy which is used by the phone to store messages sent from the phone. When I move a sent message from the local folder to the server folder, it is displayed by the phone as if it were moved there (it appears merged into the list of server stored messages). But in fact, it is never copied to the server.

birefringence ( 2014-03-04 21:58:27 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-12-23 21:42:20 +0300

birefringence gravatar image

Ok, this seems to be fixed in 1.1.1.27.

After recreating my account, there are no duplicated folders anymore and sent e-mails actually end up in the "Sent" folder on the server.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2014-03-01 22:27:50 +0300

Seen: 238 times

Last updated: Dec 23 '14