SSH & locale

asked 2014-03-03 15:16:35 +0300

Aequanix gravatar image

When I ssh to my device it seems todo something weird to the LANG setting.

locale

gives

LANG=
LANGUAGE=

however I was expecting

LANG=de_DE.UTF-8

as in fingerterm as well as on the ssh-client side.

What am I doing wrong?

(MOSH refuses to work because of this feature)

edit retag flag offensive close delete

Comments

For me I get just the normal output:

    LANG=en_EN.UTF-8
zlatko ( 2014-03-03 15:32:24 +0300 )edit

It's supposed to be the system language. Yours seems to be british english. Mine ist german. The problem however is that it remains empty when connecting via ssh.

Aequanix ( 2014-03-03 15:35:36 +0300 )edit

Yes, I am just telling you that the issue seems to be with your device/config. I get expected locale either via SSH or on device. I do not know where is the issue, but looks not be general Jolla problem.

zlatko ( 2014-03-03 15:39:06 +0300 )edit

Hm, I haven't tinkered with neither my sshd nor my locale settings on the Jolla. The ssh-client isn't configured for locale forwarding as well.

Aequanix ( 2014-03-03 15:42:23 +0300 )edit

SSHing here (over USB net should that make any difference) and my LANGUAGE, LC_ALL are unset but everything else (LC_* and LANG) are all en_GB.UTF-8 which is what I would expect given my location.

steph ( 2014-03-03 22:57:57 +0300 )edit