Ask / Submit
2

Allow double-tap to unlock even if proximity sensor is covered [not relevant]

asked 2014-03-04 13:50:28 +0200

updated 2014-12-01 20:44:23 +0200

simo gravatar image

Edit 11.06.2014: I decided to close this question, because such a change would not be practicable at all.


Sometimes, when my Jolla lies in front of me on the table and I try to unlock it with a double-tap on the screen, it does not work, because I accidentally cover the proximity sensor with my hand/fingers (held 1-2cm over the sensor). It then takes me multiple tries, until I notice that I am actually covering the sensor.

My suggestions:

  • Add a setting to allow to unlock the phone even with covered proximity sensor
  • Allow a double-double-tap to unlock the phone
  • Make proximity sensor less sensitive (currently, when I hold my finger 2-3cm over the sensor, the sensor recognizes covered-status)

Edit: Changed ordered list to unordered list to clarify that these suggestions doesn't depend on each other and added third suggestions to make proximity sensor less sensitive.

edit retag flag offensive reopen delete

The question has been closed for the following reason "question is not relevant or outdated" by ejjoman
close date 2014-06-11 16:20:01.156798

Comments

I noticed this too. It happens mostly when I hold the phone upside-down.

mikelima ( 2014-03-04 13:55:57 +0200 )edit
1

This should definitely be an optional setting; my Jolla lives in my pocket and I can definitely foresee a lot of butt dialing this way.

Elliott ( 2014-03-04 16:22:12 +0200 )edit

I don't think this should be enduser setting at all, unless with huge red warning. If they put all settings available from command line into settings it will be extremely cluttered/user unfriendly

szopin ( 2014-03-04 16:23:21 +0200 )edit

@szopin It's just one ComboBox. "Double-Tap to unlock: Disable|Enable|...". I don't understand where the problem is :)

ejjoman ( 2014-03-04 16:51:42 +0200 )edit

If you check mcetool there are plenty of options, if they would all end up in settings finding the one you need will become troublesome, especially adding an option that could potentially be problematic for a lot of users (disabling proximity activated doubletap can result in unwanted phone activity in pocket incurring costs...), then again a simple on/off for double tap could be useful, I had problem with one pants, both lumia 920 and Jolla would wake up in them (possibly radioactive paint was fooling the proximity sensor)

szopin ( 2014-03-04 17:03:17 +0200 )edit

3 Answers

Sort by » oldest newest most voted
8

answered 2014-03-05 10:13:05 +0200

spiiroin gravatar image

1st off: It might not even be proximity sensor that is causing the failures. The next update has fixes to double tap and power key handling both in kernel and middleware levels.

About the settings: "mcetool --set-doubletap-wakeup=always" does not work as expected: the double tap events are emitted, just to be ignored due to proximity - I need to fix this. For testing purposes using "mcetool --set-doubletap-wakeup=always --set-ps-mode=disabled" does the trick, but then proximity sensor is not used at all (and assumed not covered).

About the power consumption: In the default operation mode the double tap detection is powered off when proximity is covered. When double tap detection is active and something capacitive touches the panel, the power consumption is about 10 times more than what the proximity sensor takes. Thus disabling proximity sensor, leaving double tap detection active and then putting the device in to pocked - display facing skin side - could reduce the standby time by roughly two thirds (and potentially allow false positive double taps).

edit flag offensive delete publish link more

Comments

Thank you for that answer!!

torcida ( 2014-03-05 10:39:13 +0200 )edit

Thank you. Then I will wait for the next update and check if fixes my issues :)

ejjoman ( 2014-03-05 11:27:14 +0200 )edit

Wow, that would mean leaving Jolla face down on the desk will increase standby time? Or was the pocket example assuming constant contact with skin?

szopin ( 2014-03-06 10:15:22 +0200 )edit

@szopin: A wee bit perhaps, but whether the display is facing up or down does not matter that much. The pocket example is more about: Trying to get minor improvements via disabling the proximity sensor easily leads into big drainage / logic problems elsewhere.

spiiroin ( 2014-03-06 11:48:53 +0200 )edit

I had quite a bit of problems with the double tap wake stop working, and also the on call screen being turned of all the time so i could not hang up the call because proxy sensor turned of the screen no matter what.

Sometimes it halped to clean up the screen, and the proxy sensor staerted working for a while. but at some point that didn't work either and had to reboot.

Changed the CPU/GPU governor to performance few days ago(can't find the command to do this) and since then the double tap wake has been working better.

Whippler ( 2014-05-23 12:10:48 +0200 )edit
3

answered 2014-03-04 14:16:26 +0200

szopin gravatar image

updated 2014-03-04 14:17:57 +0200

You can set it through mcetool:

mcetool --set-doubletap-wakeup= never|always|proximity

Always should work, but most likely will wake up in your pocket very often, so expect some random messages/calls (to install mcetool: 'pkcon install mce-tools')

edit flag offensive delete publish link more
3

answered 2014-03-04 18:22:47 +0200

ray-ven gravatar image

I'd like to vote against your suggestion. I think this will cost battery. If I get this right, the device goes to a less power-consumtion mode when it is in your pocket (no light). You can use the button instead. But, I've been experiencing this too, when I put my phone in my bicycle-pouch for navigation (sensor is covered because the transparent part is smaller than jollas display). Still - IF this is because of powersaving - I'd prefer the button.

edit flag offensive delete publish link more

Comments

Why should this lead to a higher power consumption? Sorry, I don't get it.

ejjoman ( 2014-03-04 18:25:52 +0200 )edit

Should actually be a bit powersaving as the proximity sensor would be off at all times when locked

szopin ( 2014-03-04 18:27:20 +0200 )edit

well, I'm not sure about this - but the touch-part of the screen needs to be powered for the double-tab thing - so the phone should need less power when touch-part is off. And I think touch-part needs a lot more power than proximity

ray-ven ( 2014-03-04 18:28:47 +0200 )edit

Nobody said, that the proximity sensor should be turned off completely. It was a suggestion. As you can see, there are two other suggestions in my question.

ejjoman ( 2014-03-04 18:31:33 +0200 )edit

i think we're still missunderstanding eachother. when dark --> touch-part off --> less power consumption. bright area --> touch on --> more powerconsumption. Your sugggestion: touch always on --> never less power consumption.

Don't know how to explain in other words, but still, I'm against this, if this leads to batterydrain.

ray-ven ( 2014-03-04 18:35:03 +0200 )edit

Question tools

Follow
1 follower

Stats

Asked: 2014-03-04 13:50:28 +0200

Seen: 2,718 times

Last updated: Jun 11 '14