We have moved to a new Sailfish OS Forum. Please start new discussions there.
15

Bug: mobile network switches on automatically after being manually switched off

asked 2014-03-06 16:14:21 +0200

Jupp3 gravatar image

Have both mobile & wireless enabled. Phone should be connected to wlan.

1)In settings, switch wlan off. 2)Wait a second, and switch mobile network off aswell. 3)After a few seconds, mobile network will be automatically switched back on.

I guess this happens when mobile network is disabled while the connection is being formed?

edit retag flag offensive close delete

Comments

1

There's some misunderstanding then. Always assumed those 2 middle icons at top of settings to be "allow wlan / 3g connections", and the device would form then as needed / possible, and not switch them back on whenever it decides.

I still wonder why these two cases behave differently:

(set from top of Settings)

1)Wlan on, 3G off. Connected to Wlan. Disable Wlan

=>3G stays off.

2) Wlan on, 3G on. Connected to Wlan. Disable Wlan, THEN disable 3G

=> 3G is switched back on after a few seconds.

Jupp3 ( 2014-03-06 17:12:09 +0200 )edit
1

@Markkyboy please don't mislead him, the 2 toggles at the top of Settings are just shortcuts to those in Settings/System/Mobile Network or WLAN. Take some time to read his post.

Sthocs ( 2014-03-06 18:29:03 +0200 )edit

I assumed they were shortcuts (or similar) too. However this bug / "normal behavior" works even without using 3g shortcut, by clicking really fast. Disable it on mobile network page (after disabling wlan first) and after a few seconds, it's back on.

So, the question remains: Should the OS be able to turn 3G network connection on at will in ANY case?

And can anyone else reproduce this?

Jupp3 ( 2014-03-06 18:56:51 +0200 )edit

@Sthocs - Yes, I know they are short cuts in settings, but the behaviour of those short cuts is determined by the actual settings for either WLAN or Mobile Internet. How have I mislead?, more to the point, why don;t you answer the question if you know better?

Spam Hunter ( 2014-03-06 19:08:24 +0200 )edit

@Markkyboy it's not a question it's a bug report. What settings for WLAN or Mobile Internet are you talking about? I repeat, those are shortcuts: enable WLAN/Data from the shortcut, and got in Settings/System/..., they will be enabled. Disable them from the shortcuts and go to Settings/System/..., they will be... disabled! That's the idea behind a "shortcut", it's equivalent :)

Sthocs ( 2014-03-06 19:24:55 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-03-06 20:27:01 +0200

Jupp3 gravatar image

I think this has been confirmed a bug, that doesn't only affect the initial poster (me).

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2014-03-06 16:14:21 +0200

Seen: 243 times

Last updated: Mar 06 '14