Ask / Submit
2

Hungarian keyboard layout [answered]

asked 2013-12-27 01:19:00 +0300

adiz0r gravatar image

It would be really nice if SailfishOS also carried a Hungarian keyboard layout. Unfortunately there are 2 special Hungarian vowels which are not yet accessible with the current English layout, I mean, when pressing the matching unaccented characters for longer and selecting from the pop-up menu:

o -> ő u -> ű

All the other accented vowels could be typed well (á, é, í, ó, ö, ú, ü). Of course, a dedicated keyboard layout would be much more comfortable.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by CsTom
close date 2014-01-08 21:25:14.325737

Comments

About the missing letters, see this: https://together.jolla.com/question/1104/bug-letters-o-and-u-missing/

Venemo ( 2013-12-27 01:24:26 +0300 )edit

By the way, creating a custom keyboard layout is quite easy; I'm probably going to create a Hungarian layout for myself and will share if you're interested.

Venemo ( 2013-12-27 01:25:43 +0300 )edit

Of course I am. :) And many thanks.

adiz0r ( 2013-12-27 01:31:00 +0300 )edit

@Venemo can you share steps to create new layout? I need to create one for another language. I checked Maliit webpage, but Jolla dedicated guide would be useful.

Hess ( 2013-12-27 01:35:03 +0300 )edit

@Hess see the answer from @pnuu

Venemo ( 2013-12-27 13:12:03 +0300 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2013-12-27 11:21:33 +0300

pnuu gravatar image

Here is a link to a way to create custom kyeboard layouts.

edit flag offensive delete publish link more

Comments

Thank you!

Venemo ( 2013-12-27 13:12:27 +0300 )edit
0

answered 2013-12-27 15:46:28 +0300

Venemo gravatar image

I created a Hungarian QWERTZ layout (inspired by the HU layout of the Nokia N9): it's the same as English but deadkeys are added to allow inserting Hungarian accented letters.

Here is the layout with instructions on how to use it:
http://talk.maemo.org/showpost.php?p=1401011&postcount=68

Note: someone else also created a different Hungarian layout:
http://talk.maemo.org/showpost.php?p=1400743&postcount=57 but for me, this crowded layout is much harder to type on (and it's still a hassle to type ő and ű) so that's why I created my own.

edit flag offensive delete publish link more
0

answered 2013-12-28 15:02:29 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2013-12-28 17:13:19 +0300

Hess gravatar image

Köszönöm szépen. Now I can start bothering my hungarian friends again...

Just a few additions:

  • It should be [hu.qml], not [ca.qml] that will be added to layouts.conf
  • Found on another thread: layouts.conf will be overridden on a system upgrade. But it also seems that every file ending with .conf in the directory /usr/share/maliit/plugins/com/jolla/layouts/ will be read, so I added the definition to local-layouts.conf and it seems to be working fine. This file is preserved during system upgrades (checked with the Update 2)
  • The problem with the solution above: what happens when Jolla adds their own official version of a hungarian keyboard and they are both "Magyar, HU"? Maybe the name and languageCode should be changed somehow. Have to test what works.
    • played around a bit and it appears that the layouts are identified by the file name, not the language code:
      • if there are several entries with the same name, e.g., [hu.qml], then the last one is used. I didn't check the order of files when reading them, only checked with one file repeating the same entry with different names.
      • if the name of section points to an non-existing file, e.g., [hu2.qml], then obviously keyboard input is not working, although it appears in options. Checked with Notes application and I was not able to select this layout, it fell back to the previous selection.
      • so far I have observed that there is only 1 place where language code is used. It is on the space bar in the keyboard to display active keyboard. If there are several entries with the same languageCode, then user cannot distinguish them by the label of the space bar.
edit flag offensive delete publish link more

Comments

Hey, thank you for spotting the [hu.qml] mistake - it's fixed!

Venemo ( 2013-12-28 15:07:05 +0300 )edit
0

answered 2013-12-28 16:02:54 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2013-12-28 16:02:54 +0300

Jouni Ahto gravatar image

Update to my previous answer:

There seem to be some restrictions in character sets in the texts that can be added to /usr/share/maliit/plugins/com/jolla/layouts/layouts.conf (or, in my case, local-layouts.conf). This seems to be working fine:

[egy_igazan_jo_magyar_billentyu.qml] name=Billentyű languageCode=ÉN-HU

Should not conflict with possible upgrades from Jolla. No, egy_igazán_jó_magyar_billentyű.qml just didn't work

edit flag offensive delete publish link more

Question tools

Follow
3 followers

Stats

Asked: 2013-12-27 01:19:00 +0300

Seen: 409 times

Last updated: Dec 28 '13