Ask / Submit

Don't recognize connecting Jolla to my PC (via USB) [duplicate]

asked 2014-03-13 09:51:45 +0200

vicentpavel gravatar image

updated 2015-01-14 12:37:13 +0200

eric gravatar image

Hello Sailors,

I connect my Jolla to my Kubuntu 13.10 and Kubuntu 10.04 and it only recognize Jolla as a camera device and I cannot browse the file system. Does anyone have the same problem or the solution of it? By the way the kernel detect it but later it doesn't appear on my file system: #dmesg [ 2088.302470] usb 2-1.6: new high-speed USB device number 6 using ehci_hcd #fdisk -l It doesn't appear.

Thanks in advance.

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Tanghus
close date 2014-03-13 15:36:16.397731

2 Answers

Sort by » oldest newest most voted

answered 2014-03-13 10:20:16 +0200

Kim gravatar image

Jolla does not allow access to the phone as a storage device, but uses the MTP protocol, and only allows access to the phone memory.

When the phone is connected to your Kubuntu via USB (as PC connection), you shuold be able to see the phone in Dolphin in the side pane under network and MTP. (This is after memory, it may be named differently).

If not you may need to install the MPT drivers.

edit flag offensive delete publish link more


Is it the MTP drivers that needs to be installed?

vattuvarg ( 2014-03-13 13:21:47 +0200 )edit

I am running Kubuntu 13.10 and can access the phone. Very often without any problem, sometimes it takes a bit time to get access to the phone memory. I assume you need to install kio-mtp via muon package installer or apt-get install. Probably you will not get mtp support for 10.04 unless you activate the kde backports-ppa Hope it helps.

je ( 2014-03-13 14:07:54 +0200 )edit

answered 2014-03-13 15:36:02 +0200

Tanghus gravatar image

This has been asked and answered several time

edit flag offensive delete publish link more

Question tools

1 follower


Asked: 2014-03-13 09:51:45 +0200

Seen: 745 times

Last updated: Mar 13 '14