We have moved to a new Sailfish OS Forum. Please start new discussions there.

Suggestion: Setting to stop @ auto-return

asked 2013-12-27 08:20:47 +0300

msknight gravatar image

updated 2013-12-27 09:01:43 +0300

eric gravatar image

Switching back to letters every time I press the @ sign is annoying, especially when entering passwords and system codes. I hate it on iOS 7 and it is driving me nuts on Sailfish as well. I mean, if all you're entering is e-mail addresses then i can see the point, but it is driving me loop-de-loop. There are times when being helpful actually gets in the way ... and this ... for me ... is one of those times!

edit retag flag offensive close delete


@msknight It would be beneficial if you kindly use the idea tag for your suggestions rather than having it as a tag and in the title. Idea tag is featured, suggestion is not and they're both pretty close. Let's combine them and crop the suggestion tag, thank you.

eric ( 2013-12-27 09:01:27 +0300 )edit

Yes that should only happen when inputMethodHints are set to ImhEmailCharactersOnly

Tanghus ( 2013-12-27 09:14:45 +0300 )edit

@eric OK - how about I stop reporting and suggesting alltogether? That'll save you a load of editing. Bye!

msknight ( 2013-12-27 18:43:45 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2013-12-30 17:46:51 +0300

Pekka Vuorela gravatar image

I wouldn't restrict this functionality to ImhEmailCharactersOnly since email addresses can be often typed into free text fields. But it's an option to turn if off for password fields.

Going back to main layout can be avoided with multitouch, holding ?123 down with one finger while typing.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

1 follower


Asked: 2013-12-27 08:20:47 +0300

Seen: 78 times

Last updated: Dec 30 '13