We have moved to a new Sailfish OS Forum. Please start new discussions there.
6

Cannot update to 1.0.4.20 [answered]

asked 2014-03-17 23:12:46 +0300

yanoo gravatar image

updated 2014-03-19 14:31:18 +0300

eric gravatar image

I'm getting notification about system update to 1.0.4.4 but when starting download after couple of seconds it stops with error saying that cannot perform update for Untitled.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by molan
close date 2014-09-24 15:22:10.812066

Comments

Did not experience any problems with the update which now shows 1.0.4.20 and so far all appears to be working. Will need to test a bug I previously reported.

Richard

richardski ( 2014-03-18 00:54:39 +0300 )edit

5 Answers

Sort by » oldest newest most voted
2

answered 2014-03-17 23:24:18 +0300

sevanteri gravatar image

updated 2014-03-17 23:24:50 +0300

Running command "ssu release 1.0.4.20" helped with this. I did ran it as root even though I'm not sure if it can be done as a normal user.

edit flag offensive delete publish link more

Comments

When I did this I've got Changing release from 1.0.4.4 to 1.0.4.20 Your device is now in release mode! but update from Shop still breaks. How can I perform in another way?

yanoo ( 2014-03-18 00:10:41 +0300 )edit

Same situation here. Openrepos are disabled.

xneo ( 2014-03-18 00:18:03 +0300 )edit

I have the same problem too...

Andrer757 ( 2014-03-18 01:20:57 +0300 )edit

version --dup shows the following error:

Fatal error: File './qt/armv7hl/qtscenegraph-adaptation-0.0git43.1837baf-1.1.6.armv7hl.rpm' not found on medium 'https://releases.jolla.com/releases/1.0.4.20/jolla/armv7hl/'

[root@localhost nemo]# ssu release Device release is currently: 1.0.4.20

xneo ( 2014-03-18 08:16:21 +0300 )edit

Same story here. Reboot did not help. "ssu release 1.0.4.20" did not help either.

k79 ( 2014-03-18 09:18:46 +0300 )edit
1

answered 2014-03-18 00:40:09 +0300

Quantor gravatar image

Rebooting helped for me. After rebooting the device I triggered the update manually via Settings -> About product. Now 1.0.4.20 was offered.

edit flag offensive delete publish link more

Comments

helped, thanks!

yanoo ( 2014-03-18 01:24:02 +0300 )edit

Have to say, this wasn't the solution for me, but glad it worked.

sevanteri ( 2014-03-18 07:23:43 +0300 )edit

Likewise, rebooting was not the solution for me.

avs ( 2014-03-19 06:57:39 +0300 )edit
1

answered 2014-03-18 10:09:40 +0300

k79 gravatar image
ssu release 1.0.4.20
pkcon update

did help me. After that I manually triggered the update and it worked.

edit flag offensive delete publish link more
0

answered 2014-03-18 08:53:11 +0300

xneo gravatar image

updated 2014-03-18 08:55:49 +0300

Okay... I have a problem doing the update. The Update showed up yesterday. After that I disabled all "openrepo" repositorys.

    [root@localhost nemo]# ssu lr
Enabled repositories (global):
 - adaptation0 ... https://store-repository.jolla.com/releases/1.0.4.20/jolla-hw/adaptation-android-common/armv7hl/
 - adaptation1 ... https://store-repository.jolla.com/releases/1.0.4.20/jolla-hw/adaptation-qualcomm-sbj/armv7hl/
 - aliendalvik ... https://store-repository.jolla.com/releases/1.0.4.20/aliendalvik/SbJ/
 - apps        ... https://releases.jolla.com/jolla-apps/1.0.4.20/armv7hl/
 - eas         ... https://store-repository.jolla.com/features/1.0.4.20/eas/armv7hl/
 - hotfixes    ... https://releases.jolla.com/releases/1.0.4.20/hotfixes/armv7hl/
 - jolla       ... https://releases.jolla.com/releases/1.0.4.20/jolla/armv7hl/
 - xt9         ... https://store-repository.jolla.com/features/1.0.4.20/xt9/armv7hl/

Enabled repositories (user):
 - home  ... https://download.jollamobile.com/home:/honeybadger/latest_armv7hl/
 - store ... https://store-repository.jolla.com/SbJ/armv7hl/

Disabled repositories (global, might be overridden by user config):

Disabled repositories (user):
 - openrepos-NielDK           ... http://sailfish.openrepos.net/NielDK/personal/main
 - openrepos-Penguin          ... http://sailfish.openrepos.net/Penguin/personal/main
 - openrepos-Schturman        ... http://sailfish.openrepos.net/Schturman/personal/main
 - openrepos-Sfiet_Konstantin ... http://sailfish.openrepos.net/Sfiet_Konstantin/personal/main
 - openrepos-balta            ... http://sailfish.openrepos.net/balta/personal/main
 - openrepos-basil            ... http://sailfish.openrepos.net/basil/personal/main
 - openrepos-coderus          ... http://sailfish.openrepos.net/coderus/personal/main
 - openrepos-djselbe,k        ...
 - openrepos-[Dllelectronics  ...
 - openrepos-llelectronics    ... http://sailfish.openrepos.net/llelectronics/personal/main
 - openrepos-mike7b4          ... http://sailfish.openrepos.net/mike7b4/personal/main
 - openrepos-djselbeck        ... http://sailfish.openrepos.net/djselbeck/personal/main
 - openrepos-miska            ... http://sailfish.openrepos.net/miska/personal/main
 - openrepos-tanghus          ... http://sailfish.openrepos.net/tanghus/personal/main
 - openrepos-vasvlad          ... http://sailfish.openrepos.net/vasvlad/personal/main

But I could not download the update due to an Error showing up. Manual updating on the shell showed the following:

Last login: Tue Mar 18 07:15:17 2014 from de-l072489.lan

NOTICE: Env value ignored QT_GSTREAMER_CAMERABIN_FLAGS=15 ,--- | SailfishOS 1.0.3.8 (Naamankajärvi) (armv7hl) '---

 [nemo@localhost ~]$ version --dup
Refreshing cache              [=========================]
Waiting in queue              [=========================]
Waiting for authentication    [=========================]
Waiting in queue              [=========================]
Starting                      [=========================]
Refreshing software list      [=========================]
**Fatal error: Authentication failed (is SSU set up correctly?)**
Getting upgrades              [=========================]
Waiting in queue              [=========================]
Waiting for authentication    [=========================]
Waiting in queue              [=========================]
Starting                      [=========================]
Refreshing software list      [=========================]
Resolving dependencies        [=========================]
Installing updates            [=========================]
Downloading packages          [=========================]
**Fatal error: File './qt/armv7hl/qtscenegraph-adaptation-0.0git43.1837baf-1.1.6.armv7hl.rpm' not found on medium 'https://releases.jolla.com/releases/1.0.4.20/jolla/armv7hl/'**


REBOOT NOW, unless you need to investigate update issues, or know what
you're doing (or both).
All bugs you encounter until reboot are features unless you meet one of the
criteria from the previous sentence.
edit flag offensive delete publish link more

Comments

Okay, now I set my phone back to factory defaults (1.0.2.5) an the same problem as before. I think the major issue is

"Fatal error: Authentication failed (is SSU set up correctly?)"
xneo ( 2014-03-18 10:34:47 +0300 )edit
0

answered 2014-03-18 22:01:07 +0300

Moskonfyt gravatar image

After manually triggering the update as shown on top, my phone doesn't function... screen keeps flashing of and on and cannot press anything. it's frozen.... do i need to reload the OS? can i download the 1.0.4.20 somewhere?

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2014-03-17 23:12:46 +0300

Seen: 1,104 times

Last updated: Mar 18 '14