[BUG] Mobile Data icon "greyed out" on Settings app cover even if switch is ON [released]

asked 2014-03-18 01:23:42 +0300

Whippler gravatar image

updated 2015-08-28 13:42:19 +0300

molan gravatar image

I found a little glitch. The mobile data icon on the Settings app cover becomes "greyed out" (as if it is inactive) when it actually is enabled, after e.g. checking for new mail. Steps to reproduce:

  • Enable Mobile Data:

image description

  • Go to multitasking home screen (mobile data icon is in its "enabled" state):

image description

  • Check for new mail:

image description

  • Now mobile data icon is in its "disabled" state:

image description

  • If you go into the settings app though, you can see that the mobile data switch is still ON!

image description

This doesn't affect internet connection at all, but I still felt it would be the right thing to report this anyway. I'm afraid my screenshots are a little bit washed out, but you should easily be able to reproduce this (I hope).

EDIT: Still not fixed in Paarlampi (

EDIT 2: Seems fixed in Saapunki (, please confirm [CONFIRMED].

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by nthn
close date 2014-06-10 12:33:22.385321



Yes, I can confirm this, but you should be more clear about which cover you mean. Steps to reproduce:

  1. Turn on internet from Settings.
  2. Close Settings.
  3. Open Settings and minimize them.
nodevel ( 2014-03-18 11:05:22 +0300 )edit

Disappears after it turns to the circle for a moment (syncing emails?)

szopin ( 2014-03-18 19:40:07 +0300 )edit

This not-superimportant-but-still-a-bit-annoying thing is still present in

By the way, this question has a later duplicate - but with a better explanation (with pictures) - over at "[BUG] Mobile Data icon "greyed out" on Settings app cover even if switch is ON":

  • open Email, minimise to Cover

  • open Settings, have Mobile data as one of the first six shortcuts so it's visible on the Settings Cover, (if already enabled: disable Mobile data), enable Mobile data, minimise to Cover - the icon for Mobile data should now be visibly enabled

  • use Cover on Email to check for new e-mail

  • the icon for Mobile data on the Settings Cover now shows as disabled, but when opening Settings, it is still enabled (as it should be)

phle ( 2014-04-13 12:39:40 +0300 )edit

I closed my one and copied it back here.

Orologiaio ( 2014-04-13 16:50:02 +0300 )edit

Yes... Same issue here - hope they'll fix it with the next update.

torcida ( 2014-04-14 20:12:02 +0300 )edit