We have moved to a new Sailfish OS Forum. Please start new discussions there.
0

After update, no more ssh access [answered]

asked 2014-03-18 09:25:49 +0300

wcr gravatar image

updated 2014-03-19 11:43:44 +0300

eric gravatar image

Hello, I followed all the suggestions about disabling openrepos etc, updated, the telephone works nicely - but I cannot connect through ssh anymore. What to do?

It seems at least one other user has the same problem

The response is this

ssh nemo@192.168.1.31

ssh: connect to host 192.168.1.31 port 22: No route to host

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by wcr
close date 2014-03-20 15:50:43.170135

Comments

A mere sidenote but apparently they swapped PC-connection and Developer mode buttons when connecting the USB cable.

fercen ( 2014-03-18 09:30:33 +0300 )edit

More info (WLAN/USB, password/CERT etc.) would help to verify your case. But just to help to verify, I tested ssh from laptop using WLAN with user/password, and it works for me. If you are using certificate to login, that might be different case then. Also noticed some extra messages: NOTICE: Env value ignored QT_GSTREAMER_CAMERABIN_FLAGS=15 NOTICE: Env value ignored QT_WAYLAND_RESIZE_AFTER_SWAP=1 Probably harmless messages. I always use 'What is my IP' app to see that Jolla is really connected to WLAN instead of 3G. Another 'feature' I have noticed is that if Jolla screen is blank, you cannot connect (=needs to wake up with double tap first).

targon ( 2014-03-18 09:50:58 +0300 )edit

For me SSH access is working fine.

tvicol ( 2014-03-18 10:28:03 +0300 )edit

I thought I had commented on this before, but the short situation is this: When I got my jolla, ssh worked easily, I then installed openssh which is a broken package, and then ssh no longer worked. I then did a factory reset and everything was fine again until yesterday's update. This time, I did not install anything over the update. But ssh just does not reply anymore. This is all through WLAN and without anything particular otherwise. Maybe the broken openssh made it into the update?

wcr ( 2014-03-18 16:31:00 +0300 )edit

@wcr - You may also check if your wifi router allow communication between clients.

tvicol ( 2014-03-18 16:33:35 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-03-19 02:38:31 +0300

amanita gravatar image

Maybe you could try to disable and then enable developer mode again. This was helping in my case, where ssh wasn't working correctly.

edit flag offensive delete publish link more

Comments

will try when I am back on the home wlan, thank you!

wcr ( 2014-03-19 13:39:32 +0300 )edit

I posted a solution over at the "Important steps to do before updating"-thread. So have a look there

Regards,

J4ZZ ( 2014-03-20 05:59:21 +0300 )edit

Indeed, disabling and enabling developer mode solved the problem, thank you very much (to be safe, I rebooted in-between, not sure this was necessary). I shall close the question then.

wcr ( 2014-03-20 15:50:23 +0300 )edit

Stats

Asked: 2014-03-18 09:25:49 +0300

Seen: 507 times

Last updated: Mar 19 '14