Ask / Submit
20

Important features missing in 1.0.4.20 [subjective]

asked 2014-03-18 10:05:17 +0300

rod gravatar image

updated 2014-03-18 11:57:39 +0300

Yesterday I updated my Jolla. I'm pleased to say that I encountered no problems or glitches. Thanks to the Jolla team for the ongoing work!

However, the updated didn't include any improvements I consider paramount in order to use the phone professionally, I really need third-party CalDav (+CardDav if possible) support. PEAP authentication e.g. for Eduroam is still missing (I understand this is only a GUI thing but I'd like to tinker as little as possible). Exchange sync that worked with N900 still doesn't and my car cannot access the address book (PBAP). Without these, I can only use my Jolla as an expensive (non-smart) phone and I'm having difficulties replacing my old N900 (which is by no means perfect but still covers my daily tasks)

I know all of these problems have been mentioned before but I'd like to reiterate them here for a simple reason: They are all essential when using Jolla as a business device for me. It's fine to appeal to the fanciness-driven customers by nice colors/ambiances etc. but please also keep in mind that some of us care more about day-to-day functionality to get things done (tm) (sorry ;) ) Related to this is also a (probably global) search for appointments, or better sorting possibilites and avanced repeat patterns for the calendar as well as an onscreen-keyboard that can be used for searching everywhere (see my feature request). I would also prefer the different profiles like Bluetooth/WiFi should to be more easily accessible e.g. via the (for me in its current state mostly useless) pulley menu of the lock screen. Most of these features have already been available in my venerable XDA II Pocket PC with Windows CE therefore I'd really like to see them in Jolla.

Not to sound ungrateful, I really appreciate the effort that has been going into this project and I enjoy the phone nonetheless. But please also have an ear for the needs of people like me whom I'd like to give a voice with this thread.

edit retag flag offensive reopen delete

The question has been closed for the following reason "too subjective and argumentative" by Tanghus
close date 2014-03-19 01:19:30.929948

Comments

3

INCREDIBLE disappointed to see the Mail sync issue not fixed in this upate either.:(

Well it's back to the drawer for my Jolla again then....

Bj ( 2014-03-18 10:08:53 +0300 )edit
2

Mail sync seems to finally work for me after update to 1.0.4.20

lomo ( 2014-03-18 10:12:08 +0300 )edit

shouldn't this question be comments in other questions or new questions altogether?

gabriel ( 2014-03-18 10:36:06 +0300 )edit

@rod - For Exchange not working if is not a known issue please open a new thread and describe the problem, same for any other things that are not report, a huge thread like this one with many requests is not easy to follow...

VDVsx ( 2014-03-18 10:42:49 +0300 )edit

yes, these are all known questions and the single problems probably should also be comments to other questions. Yet, I decided to open a new thread to give a kind of different perspective on the recent updates and hint at a specific subgroup of Jolla users. My point probably is to switch the focus of the updates a little away from shiny/glossiness towards functionality

rod ( 2014-03-18 10:46:09 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-03-18 12:07:19 +0300

King.Toby gravatar image

I'm actually pretty happy with the update, even not all problems have been solved so far. I still have problems with my mobile data connection when leaving a wifi network. Also, caldav suppport would be great.

But, let's face it: it's just the fourth version of Sailfish OS, so let's be patient. :-)

edit flag offensive delete publish link more

Comments

2

I'm also not unhappy with it. And sure, patience is adviced. However I feel like the current focus of the updates is a little different from my wishes. You can never satisfy everyone's wishes but I feel the "business" requirements are drowend to some extent by all the upvotes for fancy features here :)

rod ( 2014-03-18 12:17:22 +0300 )edit
1

"But, let's face it: it's just the fourth version of Sailfish OS, so let's be patient. :-) No we are NOT patient. This is NOT a BETA release anymore. Now it's GA version and it MUST work.

Bluetooth issue where car cannot access the address book is catastrophic failure! This must be fix ASAP!

Jani68 ( 2014-03-18 12:19:29 +0300 )edit
1

Usually i agree with beeing patient but in this case it's a little hard since this keeps me from beeing able to use the phone at all.

Bj ( 2014-03-18 12:32:43 +0300 )edit
1

If the connection issues when leaving wifi are still there, I will consider this still a beta. A real phone has to be reliable.

Ozymandias ( 2014-03-18 12:38:12 +0300 )edit
1

I'm totally on your side, I think webdav caldav is a must have for a not beta release!

ray-ven ( 2014-03-18 13:40:06 +0300 )edit
0

answered 2014-03-18 12:01:09 +0300

dieterrams gravatar image

FOLKS: If you are still having Exchange issues with sync, delete the account and add it again with provisioning. It will not take the update if you just try to turn on provisioning within the existing account (may be a bug since it should warn you that you don't have device lock on). Since provisioning appears to be better supported, I enabled the device lock (do it before or you'll have to enter your Exchange account information an additional time). I have just tested push email and it appears to be working now.

edit flag offensive delete publish link more

Comments

2

I did this, but unfortunately it won't work with our Exchange (2007). Alas, I cannot even debug via ssh since eduroam is not functional (out of the box).

rod ( 2014-03-18 12:03:27 +0300 )edit

Most unfortunate. I'm a Office365 user, so maybe we can figure out who it'll work for and who it won't. Office365: Worked for me Exchange 2007: Did not work for Rod

dieterrams ( 2014-03-18 12:06:11 +0300 )edit

@rod - Can you please point me to the correct thread where you exposed the exchange problems ? I can try to help there.

VDVsx ( 2014-03-18 12:42:24 +0300 )edit

I don't think I described my Exchange problems in a dedicated thread as others have experienced the same problem and I didn't want to clutter the threads by a "me too". In essence it says "wrong credentials" (after ignoring the valid(!) certificate). The credentials are definetly valid (work in N900)

rod ( 2014-03-18 13:39:41 +0300 )edit

@rod - Ok up to you, we could provide you dedicate help and probably resolve your problem or at least identify it, if you don't want to bother, I won't insist more :)

VDVsx ( 2014-03-18 14:16:07 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2014-03-18 10:05:17 +0300

Seen: 630 times

Last updated: Mar 18 '14