We have moved to a new Sailfish OS Forum. Please start new discussions there.
31

[Bug] Mobile network connection is enabled by itself [fixed with 1.0.5.16] [released]

asked 2014-03-18 23:30:19 +0300

szobi gravatar image

updated 2014-04-13 23:55:22 +0300

chemist gravatar image

Although I disabled mobile network connection in settings, the data connection icon and the green online indicator for chats appear on lock screen again after a few minutes. If I open main settings, the shortcut bullet for mobile network is disabled. But in the mobile network settings section the connection is enabled. After enabling and disabling mobile network connection both icons disappear from the lock screen for a few minutes until they appear again.

My check interval for emails is set to 5 minutes. Maybe this causes mobile network connection enabling itself when it is disabled.

This bug was introduced by update 1.0.4.20.

EDIT: This problem even survives a reboot. So, at the moment I'm not able to disable my mobile network connection.

EDIT: After connecting and disconnecting to WLAN, mobile network does not enable itself.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by szobi
close date 2014-04-13 19:03:11.263746

Comments

Noticed this too, this morning (I disable mobile network (and location) manually during the night, until this is available through Ambiences) - mobile network was enabled this morning.

Tried connecting to my WLAN, but it failed to find it. Removed the connection, to add it anew, but it said out of reach (or similar). I stood right beside the router, and my computer (in the next room) is connected to it.

Tried different versions of disconnecting and/or removing my mobile network connection.
("[1.0.4.20] Settings->System->Mobile network->Internet always disabled" may be related?)

... then Settings got buggy.
It eventually started, but after quite a delay, and appeared when I opened some other app.

Finally gave up, and shut down my Jolla.
It took several minutes, so obviously something "hanged": the Jolla logo showed up fine, but the black non-backlit screen with the red LED lingered for minutes.
Now I've taken out the battery, and will leave it out for 10+ minutes.
Hopefully I can add-and-connect-to my mobile network and WLAN after that.


Ok, WLAN added, and mobile network back up and running.
Will see tomorrow, if mobile network stayed off or not.

Hm. It just enabled itself, about a minute after I had disabled it manually.

I'm going to bed now.
One more try: (mobile network still on) WLAN enabled, WLAN connected, WLAN disabled, mobile network connected, mobile network disabled. 2+ minutes, it's still off.
I'll report back tomorrow.

phle ( 2014-03-19 01:41:11 +0300 )edit

Morning report:
Mobile data has enabled itself (and is working as it's supposed to, when enabled - I got an e-mail notification visible on my Lock screen) again.

Note:
The device still seems to think that it's disabled, though
- Settings cover shows mobile data disabled, but
- favourited mobile data setting on first screen of Settings shows it enabled
and
- if I press the favourited mobile data toggle, it asks what I want to connect to - "Select internet connection: Mobile data or WLAN" ... as if it somehow has lost contact
- if I now toggle it off, it goes off, and when I toggle it on again, it connects to my mobile data as it should, "no questions asked"

This is a rather unwanted behaviour - say that I'm travelling abroad: I want to be reached by phone (so Flight mode is out of the question), but I do not want "surprise" mobile data.
Yes, I can select "Data roaming: Do not allow", but what if my mobile operator is an actor at my travel destination, but with a different price plan?

Also, when writing this now (about three hours later), I noticed that the mobile data icon on the Settings cover shows it as disabled, even though it is enabled, that is - same as
"[Bug]Data indicator on active cover doesnt work",
"[BUG] Mobile Data icon "greyed out" on Settings app cover even if switch is ON".

phle ( 2014-03-19 09:05:30 +0300 )edit

this just happened to me, had all connections disabled, and still received an whats app message.

Whippler ( 2014-03-19 10:55:53 +0300 )edit
1

This question looks like duplicate or related to https://together.jolla.com/question/26311/mobile-internet-connect-while-disabled/

Neo ( 2014-03-20 11:52:17 +0300 )edit

@Neo - Yes, and no: at least for me, this version of the bug was introduced with the 1.0.4.20 update.

(I have no idea whether my mobile network / data connection previously connected and disconnected itself during night when I slept, but at least it was disconnected in the morning.
I suspect it did not connect+disconnect, as I never received nightly e-mails until I re-connected in the morning (and I'm on an e-mail list that sends e-mails every morning at 04:00).)

phle ( 2014-03-22 08:53:18 +0300 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2014-03-19 10:50:33 +0300

szobi gravatar image

This ugly workaround seems to work for me, however only if there is a WLAN you're allowed to connect to:

  1. If the mobile network was connected by itself and the settings shortcut is disabled, enable mobile network connection shortcut in settings first.
  2. Disable mobile network connection.
  3. Connect to any WLAN you are allowed to connect to. (Only switching WLAN on and off doesn't work.)
  4. Disconnect from WLAN.
  5. Mobile network connection stays disabled.

Thus, if you are on the way and there is no WLAN you're allowed to connect to, it is not possible to disable mobile network connection at the moment.

I hope this bug will be fixed asap.

edit flag offensive delete publish link more

Comments

I don't consider it a permanent solution, but I appreciate your find as a temporary work-around - I tried it before tucking in for the night yesterday evening, and my mobile network was still disconnected this morning (in short: this quick-fix worked for me too).

(The difference from previous night's trial was step 2, where I didn't disable the mobile network prior to connecting to WLAN ... )

phle ( 2014-03-20 09:17:13 +0300 )edit
3

answered 2014-03-20 11:50:30 +0300

Neo gravatar image

I guess this problem could be related to this known bug after update 1.0.4.20: "Unfortunately, due to a (known) bug, even if you have no accounts the device will still wake up and attempt to do the sync (and then subsequently find that no valid accounts exist to sync with, and bail out of the sync process)" (see https://together.jolla.com/question/34510/severely-increased-battery-drain-after-10420-update/#post-id-34967). Maybe the phone starts the mobile connection because of this bug.

Normal behaviour should be to trigger scheduled syncs when a connection is on (either WLAN or mobile). If both connections are on, WLAN should be picked first over mobile. If both connections are switched off, scheduled sync should not be triggered. Behaviour that is not in accordance to this should be only optional.

edit flag offensive delete publish link more

Question tools

Follow
8 followers

Stats

Asked: 2014-03-18 23:30:19 +0300

Seen: 2,089 times

Last updated: Apr 13 '14